View Single Post
Old 09-29-09, 12:53 PM   #4
deadlycheese
Registered User
 
Join Date: Apr 2003
Posts: 12
Default Re: Announcement: libvdpau is moving to its own package

When I run the checkout-patch-build.sh script, I get the following error in the 'configure' step:


Checking for DPMS ... yes (using Xdpms 4)
Checking for Xv ... yes
Checking for XvMC ... no
Checking for VDPAU ... ./configure: line 4289: syntax error near unexpected token `fi'
./configure: line 4289: ` fi'


I was able to workaround this error by adding the following line between lines 4289 and 4290:
noop=noop

I'm sure there is a more elegant patch but I don't know why it is breaking in the first place.

In any case, after making that fix and then rerunning './configure --disable-x264-lavc --disable-x264', I was able to build the patched mplayer successfully.


Just thought someone might care to know.

My system:

Fedora 11, x86_64

gcc --version
gcc (GCC) 4.4.1 20090725 (Red Hat 4.4.1-2)

bash-4.0-8.fc11.x86_64 (bash provides /bin/sh on Fedora)
deadlycheese is offline   Reply With Quote