View Single Post
Old 10-03-09, 05:52 PM   #2
Registered User
Join Date: Feb 2009
Posts: 37
Default Re: Compiz 100% CPU with 190.36

Originally Posted by eXpert View Post
Today I updated my Kernel to the most recent 2.6.31-r1 for my distribution (Gentoo) and was forced to update the Nvidia driver as well. (185.18.14 would not compile - 185.18.36 is not available in Gentoo and I need the mobile GPU fix)

So I installed 190.36

Now my system freezes on a lot of actions for about 2 sec. with compiz taking 100% CPU load. Especially QT applications (Amarok, VLC) seam to cause that problem but some GTK applications as well. (Pidgin).
Opera + Flash on any page is absolutely unusable and the whole system renders more like a slide show

I have tried the "Fore synchronization between X and GLX" flag in compiz without any noticeable improvement.

Maybe someone can point me to a workaround until a new driver and/or a compiz patch
The 190.xx drivers need a more thinned-down (ie skeletal/basic) xorg.conf than the 180.xx versions.

Here is mine:

Section "Files"
	FontPath	"/usr/share/fonts/misc"
	FontPath	"/usr/share/fonts/cyrillic"
	FontPath	"/usr/share/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/Type1"
	FontPath	"/usr/share/fonts/100dpi"
	FontPath	"/usr/share/fonts/75dpi"
	FontPath	"/usr/share/fonts/TTF"

Section "ServerFlags"
	Option 		"AutoAddDevices" 		"False"
	Option 		"DontZap"	 		"False"

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"			"xorg"
	Option		"XkbModel"			"pc105"
	Option 		"XkbLayout"			"us,gr"
	Option 		"XkbOptions"			"grp:ctrl_shift_toggle,lv3:ralt_switch,eurosign:e"

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"			"/dev/input/mice"
	Option		"Protocol"			"ExplorerPS/2"
	Option		"ZAxisMapping"			"4 5"
	Option		"Emulate3Buttons"		"true"

Section "Monitor"
	Identifier	"My Monitor"
	Option		"DPMS" 				"True"
	Option 		"DPI"   			"96 x 96"

Section "Device"
	Identifier	"My Graphics Card"
	Driver		"nvidia"
	VendorName	"NVIDIA Corporation"

Section "Screen"
	Identifier	"Default Screen"
	Device		"My Graphics Card"
	Monitor		"My Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		24
		Modes		"1280x1024"
		Viewport	0 0
	Option 		"DPI"   			"96 x 96"
	Option		"AddARGBGLXVisuals"		"true"
	Option 		"TripleBuffer" 			"true"

Section "Extensions"
        Option      	"Composite"   			"enable"
Running archlinux amd64, kernel 2.6.30, nvidia 190.36, gnome 2.26, and compiz-fusion-git 2009-03-27 (0.8.3).
wantilles is offline   Reply With Quote