View Single Post
Old 10-09-09, 09:15 AM   #1
Tonglebeqk
Registered User
 
Join Date: Jun 2008
Posts: 30
Default is this a common problem? (opengl)

Using KDE 4.3. If I run glxgears without compositing, I get ~17.4k FPS. When I enable compositing, glxgears stutters horribly, but says it goes at 5k FPS. Why is performance totally killed when compositing is enabled? I have an 896mb gtx260 which should be more than enough for this...here comes my xorg.conf if it makes any difference (also am using 190.36 drivers, but this issue has been with older drivers as well):

PHP Code:
aaron@h4x0r ~ $ cat /etc/X11/xorg.conf
Section
"ServerLayout"                
    
Identifier     "Layout0"          
    
Screen      0  "Screen0" 0 0      
EndSection                            

Section
"ServerFlags"
  
Option "DontZap" "off"
EndSection              

#Section "Monitor"
#   Identifier     "CRTMonitor"
#  VendorName     "Envision"   
# ModelName      "EFT720"      
#    HorizSync       30.0 - 72.0
#    VertRefresh     50.0 - 130.0

Section "Monitor"
    
Identifier "LCD"
    
VendorName "Samsung"
    
ModelName  "2232BW"
    
HorizSync 30.0 - 72.0
    VertRefresh  50.0
- 130
#    Option "Mode" "1680x1050"
#Option         "metamodes" "1680x1050_60 +0+0;
EndSection

Section
"Device"
    
Identifier     "NvidiaCard"
    
Driver         "nvidia"
    
VendorName     "NVIDIA Corporation"
    
Option "OnDemandVBlankInterrupts" "true"
    
Option "NoLogo" "TRUE"
    
Option "Coolbits" "1"
    
Option "CursorShadow" "true"
    
Option "CursorShadowXOffset" "10"
    
Option "CursorShadowYOffset" "10"
    
Option "AddARGBGLXVisuals" "true"
    
Option "MultisampleCompatibility" "true"
    
Option         "UseEvents" "false"
    
Option         "TripleBuffer" "1"
     
Option         "DamageEvents" "true"
    
Option         "InitializeWindowBackingPixmaps" "1"
    
Option         "PixmapCacheSize" "134217728"
EndSection

Section
"Screen"
    
Identifier     "Screen0"
    
Device         "NvidiaCard"
    
Monitor        "LCD"
    
DefaultDepth    24
    SubSection     
"Display"
       
Depth       24
    EndSubSection
EndSection

Section
"Extensions"
    
Option         "Composite" "Enable"
EndSection
Tonglebeqk is offline   Reply With Quote