View Single Post
Old 10-11-09, 07:19 AM   #19
lgolebio
Registered User
 
Join Date: Nov 2008
Posts: 15
Default Re: Announcement: libvdpau is moving to its own package

Hi, I'm trying to play the lys-20031106.avi file. It doesn't work, like other MPEG-4 files.
I have the latest nvidia drivers (190.36 beta) and succesfully compiled the "mplayer-vdpau-4789364".

Hardware
-nvidia 8600M GT DDR3

Here is the output of mplayer:
Quote:
[lukasz@xpsm1530 Desktop]$ /usr/local/bin/mplayer -vc ffodivxvdpau -vo vdpau lys-20031106.avi
MPlayer SVN-r29354-4.4.1 (C) 2000-2009 MPlayer Team
/usr/share/fonts/TTF/DejaVuSans.ttf doesn't look like a bitmap font description, ignoring.
Cannot load bitmap font: /usr/share/fonts/TTF/DejaVuSans.ttf
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing lys-20031106.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
AVI: No audio stream found -> no sound.
VIDEO: [DIVX] 1920x1080 24bpp 25.000 fps 8290.9 kbps (1012.1 kbyte/s)
Clip info:
Software: MEncoder 0.90rc5-3.2.2
Opening video filter: [expand w=0 h=-200 x=0]
Expand: 0 x -200, 0 ; -1, osd: 0, aspect: 0.000000, round: 1
Opening video filter: [pp]
================================================== ========================
Forced video codec: ffodivxvdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Unsupported PixelFormat -1
Selected video codec: [ffodivxvdpau] vfm: ffmpeg (FFmpeg MPEG-4,DIVX-4/5 (VDPAU))
================================================== ========================
Audio: no sound
Starting playback...
[mpeg4_vdpau @ 0x8956060]decoding to PIX_FMT_NONE is not supported.
[VD_FFMPEG] Trying pixfmt=0.
Unsupported PixelFormat -1
VDec: vo config request - 1920 x 1080 (preferred colorspace: MPEG-4 Part 2 VDPAU acceleration)
[PP] Using external postprocessing filter, max q = 6.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
[vdpau] query_format: Unsupported image_format 0
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
Unsupported PixelFormat -1
[mpeg4_vdpau @ 0x8956060]VDPAU decoding to PIX_FMT_NONE is not supported.
Error while decoding frame!

FATAL: Could not initialize video filters (-vf) or video output (-vo).


Exiting... (End of file)
SORRY, my fault, I didn't realize that my graphic card doesn't support vdpau MPEG-4 decoding. Sorry for bothering you.

Last edited by lgolebio; 10-11-09 at 07:40 AM. Reason: Know I know why it is not working...
lgolebio is offline   Reply With Quote