View Single Post
Old 11-03-09, 11:53 PM   #1
chepioq
Registered User
 
Join Date: Nov 2009
Posts: 5
Default Fedora12 xorg 1.7 and 190.42 segfault

Hi...
I am with Fedora12, xorg1.7 and driver 190.42
I have a segfault with 190.42 when I work with gimp;
Code:
Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x49e758]
1: /usr/bin/X (0x400000+0x619a9) [0x4619a9]
2: /lib64/libpthread.so.0 (0x7f8785e4f000+0xf320) [0x7f8785e5e320]
3: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8780c9e000+0xa4960)
[0x7f8780d42960]
4: /usr/lib64/xorg/modules/libwfb.so (wfbBltOne+0x469) [0x7f878086b9c9]
5: /usr/lib64/xorg/modules/libwfb.so (wfbOddStipple+0x170) [0x7f8780877520]
6: /usr/lib64/xorg/modules/libwfb.so (wfbFill+0x282) [0x7f878086d732]
7: /usr/lib64/xorg/modules/libwfb.so (wfbBresFill+0x71) [0x7f87808756d1]
8: /usr/lib64/xorg/modules/libwfb.so (wfbSegment+0x47e) [0x7f87808743ee]
9: /usr/lib64/xorg/modules/libwfb.so (wfbZeroLine+0xfd) [0x7f878087082d]
10: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8780c9e000+0x348e68)
[0x7f8780fe6e68]
11: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8780c9e000+0x342e90)
[0x7f8780fe0e90]
12: /usr/bin/X (miPolySegment+0x42) [0x54fbb2]
13: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f8780c9e000+0x34331d)
[0x7f8780fe131d]
14: /usr/bin/X (0x400000+0xd315b) [0x4d315b]
15: /usr/bin/X (0x400000+0x2a954) [0x42a954]
16: /usr/bin/X (0x400000+0x2c60c) [0x42c60c]
17: /usr/bin/X (0x400000+0x21c9a) [0x421c9a]
18: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f8784835b4d]
19: /usr/bin/X (0x400000+0x21849) [0x421849]
Segmentation fault at address 0x7f8774ddbb24
With Fedora11, xorg-X11-server-X11 1.6.4 and same driver (190.42) I have no problem, no segfault...

I see same problem with archlinux (see this tread http://www.nvnews.net/vbulletin/showthread.php?t=140768 )
But where is the problem: xorg1.7? driver 190.42? or twice?...
chepioq is offline   Reply With Quote