View Single Post
Old 11-07-09, 11:39 AM   #179
tradewinds
Registered User
 
Join Date: May 2009
Posts: 27
Default Re: VDPAU testing tool

I ran the test in TRACE mode, here is where the error started to occur. Note the empty information passed:

Code:
vdp_video_mixer_render(3, 4294967295, NULL, 2, 0, NULL, 8, 0, NULL, {0, 0, 1920, 1080}, 2, {0, 0, 1024, 576}, {0, 0, 1024, 576}, 0, NULL)
    -> 0
vdp_presentation_queue_display(5, 2, 0, 0, 0)
    -> 0
vdp_decoder_render(6, 9, {8, 4294967295, 68, 3, 2, 2, 0, 0, 1, 0, 1, 0, 0, 0, {{2, 2}, {15, 15}}, {8, 16, 19, 22, 26, 27, 29, 34, 16, 16, 22, 24, 27, 29, 34, 37, 19, 22, 26, 27, 29, 34, 34, 38, 22, 22, 26, 27, 29, 34, 37, 40, 22, 26, 27, 29, 32, 35, 40, 48, 26, 27, 29, 32, 35, 40, 48, 58, 26, 27, 29, 34, 38, 46, 56, 69, 27, 29, 35, 38, 46, 56, 69, 83}, {16, 17, 18, 19, 20, 21, 22, 23, 17, 18, 19, 20, 21, 22, 23, 24, 18, 19, 20, 21, 22, 23, 24, 25, 19, 20, 21, 22, 23, 24, 25, 26, 20, 21, 22, 23, 24, 25, 26, 27, 21, 22, 23, 24, 25, 26, 27, 28, 22, 23, 24, 25, 26, 27, 28, 29, 23, 24, 25, 26, 27, 28, 29, 30}}, 1, {{(ver 0) 53946, ...}})
    -> 0
vdp_video_mixer_render(3, 4294967295, NULL, 2, 0, NULL, 9, 0, NULL, {0, 0, 1920, 1080}, 2, {0, 0, 1024, 576}, {0, 0, 1024, 576}, 0, NULL)
    -> 0
vdp_presentation_queue_display(5, 2, 0, 0, 0)
    -> 2
vdp_decoder_render(6, 7, {...}, 1, {{(ver 0) 55197, ...}})
    -> 3
MPEGDecoder: decoding failed!
vdp_video_mixer_render(3, 4294967295, NULL, 2, 0, NULL, 7, 0, NULL, {0, 0, 1920, 1080}, 2, {0, 0, 1024, 576}, {0, 0, 1024, 576}, 0, NULL)
    -> 3
vdp_get_error_string(3)
    -> 'An invalid handle value was provided.'
displayFrame: vdp_video_mixer_render error : An invalid handle value was provided.
tradewinds is offline   Reply With Quote