View Single Post
Old 11-12-09, 11:32 AM   #3
blindgeek
Registered User
 
Join Date: Nov 2009
Location: Massachusetts80
Posts: 7
Default Re: display preemption with MPlayer Vdpau

Hi Stephen, thanks for the reply. I tried removing -fs while playing a test clip I got from h264info.com last night, and that didn't change anything. I still got Vdpauinfo output that to me looked ok, and the display pre-empted as it did before. ONe thing I did do though is pull new MPlayer SVN for updates, which I do routinely anyway, and that is causing me to receive slightly new output (this is probably old output, but here it is for easy reference):
MPlayer SVN-r29903-4.4.1 (C) 2000-2009 MPlayer Team

Playing The Simpsons Movie - Trailer.mp4.
libavformat file format detected.
[lavf] Video stream found, -vid 0
[lavf] Audio stream found, -aid 1
VIDEO: [H264] 1280x544 24bpp 23.976 fps 4221.4 kbps (515.3 kbyte/s)
Clip info:
major_brand: isom
minor_version: 1
compatible_brands: isomavc1
================================================== ========================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] Trying pixfmt=0.
Unsupported PixelFormat -1

And here is the new output:
[vdpau] Display preemption detected
[vdpau] Failed creating VDPAU decoder: The display was pre-empted, or a fatal error occurred.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
[vdpau] Attempting to recover from preemption.
X11 error: BadDrawable (invalid Pixmap or Window parameter)
X11 error: BadDrawable (invalid Pixmap or Window parameter)
[vdpau] Display preemption detected
[vdpau] Error when calling vdp_presentation_queue_create: The display was pre-empted, or a fatal error occurred.
[vdpau] Recovering from preemption failed
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
Unsupported PixelFormat -1
Unsupported PixelFormat -1
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
I cut out the audio stuff, but more video output:
[h264_vdpau @ 0xd607c0]decoding to PIX_FMT_NONE is not supported.
[h264_vdpau @ 0xd607c0]decode_slice_header error
[h264_vdpau @ 0xd607c0]no frame!
Error while decoding frame!
And I get about two or three more pages of the "error while decoding frame" errors. I read somewhere that someone got it working on their UBuntu system by completely disabling CPU frequency scaling. I have mine turned on, but defaulting to the performance governor, which statically sets the CPU to the highest supported frequency; I did not think this could be it, but one never knows. So after I finish this post, I'm going to boot my new kernel and see if the problem goes away. As far as altering any refresh rates, in an effort to get MPlayer to pass the video bistream exactly as is, I passed in -vf-clr to clear the video filter chain completely, and not even that had any effect. Thanks.
__________________
--
Igor
blindgeek is offline   Reply With Quote