View Single Post
Old 11-17-09, 11:35 PM   #1
Tonacatecuhtli
Registered User
 
Join Date: Dec 2007
Posts: 15
Default 190.42 nvidia / evdev issue

I'm having an issue where X will freeze intermittently, although usually when some high-graphics-card-load applications e.g. Neverwinter Nights is running. This freeze will generally last about three seconds and then everything will continue normally.

X reports backtraces like:
Code:
Backtrace:
0: X (xorg_backtrace+0x28) [0x4676d8]
1: X (mieqEnqueue+0x1eb) [0x45f9eb]
2: X (xf86PostMotionEventP+0xc8) [0x46c088]
3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7faf9ada3000+0x41d9) [0x7faf9ada71d9]
4: X (0x400000+0x76107) [0x476107]
5: X (0x400000+0x10b379) [0x50b379]
6: /lib/libpthread.so.0 (0x7faf9f92d000+0xf260) [0x7faf9f93c260]
7: /lib/libc.so.6 (__sched_yield+0x7) [0x7faf9df68377]
8: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7faf9bb4b000+0xbce275) [0x7faf9c719275]
9: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7faf9bb4b000+0xbce3ab) [0x7faf9c7193ab]
10: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7faf9bb4b000+0x8f5daf) [0x7faf9c440daf]
11: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7faf9bb4b000+0x54ce06) [0x7faf9c097e06]
12: /usr/lib64/xorg/modules/extensions/libglx.so (0x7faf9cfa8000+0x22fdd3) [0x7faf9d1d7dd3]
And thus my theory that the problem has something to do with both evdev and nvidia. From what I've seen, the backtraces always go through the nvidia code to the evdev code to the point of failure.

Things that may set my system apart from the norm would be 2 GTX 260s in SLi and xorg 1.7.1. More details in bug report file.

Has anyone else seen anything like this?
Attached Files
File Type: gz nvidia-bug-report.log.gz (31.5 KB, 88 views)
Tonacatecuhtli is offline   Reply With Quote