View Single Post
Old 11-18-09, 02:44 AM   #3
Tonacatecuhtli
Registered User
 
Join Date: Dec 2007
Posts: 15
Default Re: 190.42 nvidia / evdev issue

Thanks for the tip! Unfortunately it does not seem to have remedied my issue. I haven't had any problems with stability, per se, X hasn't locked up on me or crashed, just temporarily frozen.

Here's some example backtraces without triple buffering (in lieu of a whole new bug report file):
Code:
(WW) Nov 18 02:37:13 NVIDIA(0): WAIT (2, 6, 0x8000, 0x00007724, 0x00007734)
(WW) Nov 18 02:37:20 NVIDIA(0): WAIT (1, 6, 0x8000, 0x00007724, 0x00007734)
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: X (xorg_backtrace+0x28) [0x4676d8]
1: X (mieqEnqueue+0x1eb) [0x45f9eb]
2: X (xf86PostMotionEventP+0xc8) [0x46c088]
3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f6726ed8000+0x41d9) [0x7f6726edc1d9]
4: X (0x400000+0x76107) [0x476107]
5: X (0x400000+0x10b379) [0x50b379]
6: /lib/libpthread.so.0 (0x7f672ba62000+0xf260) [0x7f672ba71260]
7: /lib/libc.so.6 (__sched_yield+0x7) [0x7f672a09d377]
8: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0xbce275) [0x7f672884e275]
9: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0xbce3ab) [0x7f672884e3ab]
10: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0x8f5daf) [0x7f6728575daf]
11: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0x54ce06) [0x7f67281cce06]
12: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f67290dd000+0x22fdd3) [0x7f672930cdd3]

Backtrace:
0: X (xorg_backtrace+0x28) [0x4676d8]
1: X (mieqEnqueue+0x1eb) [0x45f9eb]
2: X (xf86PostMotionEventP+0xc8) [0x46c088]
3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f6726ed8000+0x41d9) [0x7f6726edc1d9]
4: X (0x400000+0x76107) [0x476107]
5: X (0x400000+0x10b379) [0x50b379]
6: /lib/libpthread.so.0 (0x7f672ba62000+0xf260) [0x7f672ba71260]
7: /lib/libc.so.6 (__sched_yield+0x7) [0x7f672a09d377]
8: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0xbce275) [0x7f672884e275]
9: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0xbce304) [0x7f672884e304]
10: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0x90404f) [0x7f672858404f]
11: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0x8f3686) [0x7f6728573686]
12: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0x5cbf74) [0x7f672824bf74]
13: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0x5cc3c6) [0x7f672824c3c6]
14: //usr/lib64/opengl/nvidia/lib/libGLcore.so.1 (0x7f6727c80000+0x5cc81f) [0x7f672824c81f]
15: /usr/lib64/xorg/modules/extensions/libglx.so (0x7f67290dd000+0x15ca69) [0x7f6729239a69]
Unfortunately without symbols they are remarkably useless to me. Has anyone seen the same pattern, evdev + nvidia?
Tonacatecuhtli is offline   Reply With Quote