View Single Post
Old 11-19-09, 09:28 PM   #8
juanino
Registered User
 
Join Date: Nov 2009
Posts: 5
Default Re: xfx GT 220 suspend prob on fedora 10

Ok. here is the solution.
echo PWRB > /proc/acpi/wakeup

Yours should look like this (yes, I know... everything is disabled).
If something is enabled, echo the device name on the left into wakeup and cat the file again to see if it is disabled. In the bios, disable all wakeup events, you'll have to use the power button to wake it up physically, keyboard wakeup wasn't reliable for me.

# cat /proc/acpi/wakeup
Device S-state Status Sysfs node
NSMB S4 disabled pci:0000:00:01.1
USB0 S4 disabled pci:0000:00:02.0
USB2 S3 disabled pci:0000:00:02.1
NMAC S5 disabled pci:0000:00:07.0
P0P1 S4 disabled pci:0000:00:04.0
HDAC S4 disabled pci:0000:00:05.0
BR10 S4 disabled pci:0000:00:09.0
BR11 S4 disabled pci:0000:00:0b.0
BR12 S4 disabled pci:0000:00:0c.0
PWRB S4 *disabled

You also have to be in Xwindows..... running in runlevel 3 or another console mode without xwindows caused suspend to work, but resume wouldn't power on the monitor. IT must be inside the nvidia X driver that the power up is sent to the monitor. I'm using fedora 12 now, with an xfx gt220.
juanino is offline   Reply With Quote