View Single Post
Old 11-20-09, 05:06 PM   #6
Tonacatecuhtli
Registered User
 
Join Date: Dec 2007
Posts: 15
Default Re: 190.42 nvidia / evdev issue

Quote:
Originally Posted by piotrq__ View Post
I'd get rid of
this: Option "PixmapCacheSize" "10000000"
that: Option "DRI" "true" #you don't have the dri module anyway
that: Option "XAANoOffscreenPixmaps" "true"
these: Option "PixmapCacheSize" "10000000" #driver knows what to do
Option "AllowSHMPixmaps" "0" #off by default
Option "BackingStore" "true" #can cause a performance degradation
Option "HWcursor" "on" #on by default

And last but not least, put this into your config:
Option "UseEvents" "false" #something's broken with G8x or newer cards and latest drivers here, so make sure it is off
Unfortunately it does not seem that all my xorg.conf cruft was the issue.

Quote:
Originally Posted by loftwyr View Post
Or better yet, reduce your xorg.conf to
Code:
Section "Device"
    Identifier     "VideoCard"
    Driver         "nvidia"
EndSection
and nothing more and see how it works
This fixes it. Specifically, turning off SLI fixes it. The problem persists with both AFR and SFR. Thankfully, turning off SLI is a good enough temporary solution.

Thanks for the ideas, everyone!
Tonacatecuhtli is offline   Reply With Quote