View Single Post
Old 11-22-09, 09:32 AM   #1
jesso
Registered User
 
Join Date: Nov 2006
Posts: 38
Default [Solved] Error when calling vdp_device_create_x11

I am using Arch Linux.

They have a libvdpau package now. So I upgrade nvidia-utils and installed libvdpau.

I get no video now on mkv.

If I uninstall libvdpau and go back to the previous nvidia-utils, no problem.

Does anyone know what the problem is?


Code:
MPlayer SVN-r29354-4.4.2 (C) 2000-2009 MPlayer Team

Playing /home/jason/media/Video/Movies/aliens_in_the_attic.mkv.
Cache fill:  2.28% (5980160 bytes)
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS), -aid 0, -alang eng
[mkv] Track ID 3: subtitles (S_TEXT/UTF8), -sid 0, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1280x688  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
[vdpau] Error when calling vdp_device_create_x11: 1
Error opening/initializing the selected video_out (-vo) device.
==========================================================================
Trying to force audio codec driver family hwac3...
Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
No accelerated IMDCT transform found
hwac3: switched to DTS, 1536000 bps, 48000 Hz
AUDIO: 48000 Hz, 2 ch, ac3, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [hwdts] afm: hwac3 (DTS through S/PDIF)
==========================================================================
[AO_ALSA] alsa-lib: conf.c:4484:(parse_args) Unknown parameter AES0
[AO_ALSA] alsa-lib: conf.c:4617:(snd_config_expand) Parse arguments error: No such file or directory
[AO_ALSA] alsa-lib: pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM hw:0,1,AES0=6
AO: [alsa] 48000Hz 2ch ac3 (1 bytes per sample)
Video: no video
Starting playback...
jesso is offline   Reply With Quote