View Single Post
Old 11-22-09, 09:17 PM   #1
archwndas
Registered User
 
Join Date: Sep 2007
Posts: 4
Default Nvidia GTX 260 performance decrease more by a factor of 2 Debian vs Sabayon Linux

Hi there,
I run the phoronix test suite 2.2.0 on both Debian and Sabayon. Both systems started X with the same xorg.conf file. Basically I copied the debian xorg.conf to /etc/X11/xorg.conf of Sabayon tree to make sure everything there is the same. I observe the same phenomenon I observed with glxgears after I run one of the OpenGL benchmarks of phoronix test suite called GLMark. Below you see what the test suite identifies as my hardware and details about the system and further below the frames per second at both systems. I attach the corresponding resume .xml files hoping that you can see them with firefox under Sabayon as they should appear. I could not see them under Sabayon as I see them under Debian. Any ideas?

Debian
------
<Hardware>Processor: Intel Core 2 Duo CPU P9700 @ 2.80GHz (Total Cores: 2), Motherboard: CLEVO M860TU, Chipset: Intel Mobile 4 Series Chipset Hub + ICH9M, System Memory: 3964MB, Disk: 320GB ST9320421AS, Graphics: GeForce GTX 260M 1024MB (550/800MHz), Monitor: Option "MetaModes" "DFP-0: nvidia-auto-select +0+0, DFP-2: nvidia-auto-select +0+0"
(--) NVIDIA(0): LEN</Hardware>
<Software>OS: Debian 5.0.3, Kernel: 2.6.30-bpo.1-amd64 (x86_64), Desktop: Xfce, Display Server: X.Org Server 1.6.5, OpenGL: 3.0.0 NVIDIA 185.18.31, Compiler: GCC 4.3.4, File-System: ext2/ext3, Screen Resolution: 1920x1200</Software>


Sabayon
-------
<Hardware>Processor: Intel Core 2 Duo CPU P9700 @ 2.80GHz (Total Cores: 2), Motherboard: CLEVO M860TU, Chipset: Intel Mobile 4 Series Chipset Hub + ICH9M, System Memory: 3956MB, Disk: 320GB ST9320421AS, Graphics: GeForce GTX 260M 1024MB (550/800MHz), Monitor: Option "MetaModes" "DFP-0: nvidia-auto-select +0+0, DFP-2: nvidia-auto-select +0+0"
(--) NVIDIA(0): LEN</Hardware>
<Software>OS: Gentoo 2.0.1, Kernel: 2.6.31-sabayon (x86_64), Desktop: KDE 4.3.3, Display Server: X.Org Server 1.6.5, OpenGL: 3.0.0 NVIDIA 185.18.31, Compiler: GCC 4.4.1, File-System: xfs, Screen Resolution: 1920x1200</Software>

This is a test of GLMark, an open-source OpenGL benchmark.
Resolution 1920x1200

Code:
Test                                   Sabayon         Debian Squeeze
-------------------------------------------------------------
Vertex Array                             1175           2267
Vertex Buffer                            1231           3021
Texture Filtering - Linear                852           2095
Texture Filtering - Mipmapped            1098           2790
GLSL Per Vertex Lighting                  946           2272
GLSL Per Pixel Lighting                   923           2148
I also performed the same test on Sabayon running XFCE4 the previous result is under KDE4.3.3 on Sabayon. The performance is independent on the Window manager. I have attached the results of the benchmark. You can view them after decompressing the tarball by opening with firefox the corresponding index.html file. There you will see some more details about my hardware. To me it seems that the kernel makes a difference somehow. I remember that after I upgraded Debian to Sid (this is not Sid but Squeeze), I got in Debian similar performance as Sabayon. I do not know what causes this slow down. No idea at all.

Please help.

Let me know if there is any other information about my systems you would like to see.

All my best,
Archwn.
Attached Files
File Type: bz2 glmark-bench.tar.bz2 (130.7 KB, 107 views)
archwndas is offline   Reply With Quote