View Single Post
Old 11-25-09, 10:23 PM   #1
colbert
Registered User
 
Join Date: Jan 2008
Posts: 33
Unhappy Mplayer+vdpau not playing h264

I am using Arch linux, mplayer package info from pacman here:

Code:
Name           : mplayer
Version        : 29776-1
URL            : http://www.mplayerhq.hu/
Licenses       : GPL
Groups         : None
Provides       : None
Depends On     : libxxf86dga  libxv  libmad  giflib  cdparanoia  libxinerama  sdl  lame  libtheora  xvidcore  zlib  libmng  libxss  live-media  libgl  smbclient  aalib  jack-audio-connection-kit  libcaca  x264>=20090416  faac  lirc-utils
                 ttf-dejavu  libxvmc  libjpeg>=7
Optional Deps  : None
Required By    : devede  gmencoder  gnome-mplayer  smplayer-svn
Conflicts With : None
Replaces       : None
Installed Size : 21988.00 K
Packager       : Unknown Packager
Architecture   : i686
Build Date     : Wed 25 Nov 2009 06:51:04 PM EST
Install Date   : Wed 25 Nov 2009 06:51:35 PM EST
Install Reason : Explicitly installed
Install Script : No
Description    : A movie player for linux
Playing an h264 encoded .MKV 720p file that I've played countless times with various versions of mplayer, VLC, xine, Myth internal player, etc. I get this output trying to use the -vc ffh264vdpau:

Code:
MPlayer SVN-r29776-4.4.2 (C) 2000-2009 MPlayer Team
141 audio & 306 video codecs

Playing Movie.mkv.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS), -aid 0, -alang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO:  [avc1]  1280x532  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
Opening video filter: [screenshot]
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] XVMC-accelerated MPEG-2.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [libdca] DTS decoding with libdca
AUDIO: 48000 Hz, 6 ch, s16le, 1536.0 kbit/33.33% (ratio: 192000->576000)
Selected audio codec: [dts] afm: libdca (DTS-libdca)
==========================================================================
AO: [alsa] 48000Hz 6ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] XVMC-accelerated MPEG-2.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
Error while decoding frame!
[h264_vdpau @ 0x899a360]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x899a360]decode_slice_header error
[h264_vdpau @ 0x899a360]no frame!
Error while decoding frame!
[h264_vdpau @ 0x899a360]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x899a360]decode_slice_header error
[h264_vdpau @ 0x899a360]no frame!
Error while decoding frame!
[h264_vdpau @ 0x899a360]B picture before any references, skipping
[h264_vdpau @ 0x899a360]decode_slice_header error
[h264_vdpau @ 0x899a360]no frame!
Error while decoding frame!
[h264_vdpau @ 0x899a360]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x899a360]decode_slice_header error
[h264_vdpau @ 0x899a360]no frame!
Error while decoding frame!
And those "Error while decoding frame!" bunches repeat until ctrl+c. I also got this a couple times:

Code:
Error while decoding frame!
[h264_vdpau @ 0x899a360]get_buffer() failed (-1 0 0 (nil))
[h264_vdpau @ 0x899a360]decode_slice_header error
[h264_vdpau @ 0x899a360]no frame!
Error while decoding frame!

Too many audio packets in the buffer: (4101 in 8255313 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

FATAL: Could not initialize video filters (-vf) or video output (-vo).


Exiting... (End of file)
While that seems to be an audio error, I will repeat that I have played this file countless times with many versions of mplayer, VLC, xine, Myth internal player, etc. with no problems at all.

Thanks for any help
colbert is offline   Reply With Quote