View Single Post
Old 11-26-09, 11:32 AM   #1
Tonglebeqk
Registered User
 
Join Date: Jun 2008
Posts: 30
Default what changed with the way nvidia detects kernel version?

On Gentoo, emerging 190.42 works just fine. When I take that same ebuild and bump the version to 195.22, the compile always fails with the following message:

Code:
>>> Emerging (1 of 1) x11-drivers/nvidia-drivers-195.22 from unknown repo
 * NVIDIA-Linux-x86_64-195.22-pkg2.run RMD160 SHA1 SHA256 size ;-) ...                                                                               [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                 [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                               [ ok ]
 * Determining the location of the kernel source code                                                                                                      
 * Found kernel source directory:                                                                                                                          
 *     /usr/src/linux                                                                                                                                      
 * Found kernel object directory:                                                                                                                          
 *     /lib/modules/2.6.31-gentoo-r6/build                                                                                                                 
 * Found sources for kernel version:                                                                                                                       
 *     2.6.31-gentoo-r6                                                                                                                                    
 * Checking for MTRR support ...                                                                                                                      [ ok ]
>>> Unpacking source...                                                                                                                                     
>>> Unpacking NVIDIA-Linux-x86_64-195.22-pkg2.run to /var/tmp/portage/x11-drivers/nvidia-drivers-195.22/work/NVIDIA-Linux-x86_64-195.22-pkg2                
>>> Source unpacked in /var/tmp/portage/x11-drivers/nvidia-drivers-195.22/work                                                                              
>>> Preparing source in /var/tmp/portage/x11-drivers/nvidia-drivers-195.22/work/NVIDIA-Linux-x86_64-195.22-pkg2 ...                                         
 * Applying NVIDIA_glx-defines.patch ...                                                                                                              [ ok ]
 * Applying NVIDIA_glx-glheader.patch ...                                                                                                             [ ok ]
 * Converting NVIDIA-Linux-x86_64-195.22-pkg2/usr/src/nv/Makefile.kbuild to use M= instead of SUBDIRS= ...                                            [ ok ]
>>> Source prepared.                                                                                                                                        
>>> Configuring source in /var/tmp/portage/x11-drivers/nvidia-drivers-195.22/work/NVIDIA-Linux-x86_64-195.22-pkg2 ...                                       
>>> Source configured.                                                                                                                                      
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-195.22/work/NVIDIA-Linux-x86_64-195.22-pkg2 ...                                         
 * Preparing nvidia module                                                                                                                                  
make -j4 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/2.6.31-gentoo-r6/build HOST_CC=x86_64-pc-linux-gnu-gcc clean module                                                                                            
If you are using a Linux 2.4 kernel, please make sure                                                                                                       
you either have configured kernel sources matching your                                                                                                     
kernel or the correct set of kernel headers installed                                                                                                       
on your system.                                                                                                                                             

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate  
output directory using either the "KBUILD_OUTPUT" or   
the "O" KBUILD parameter, make sure to specify this    
directory with the SYSOUT environment variable or with 
the equivalent nvidia-installer command line option.   

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or 
the equivalent nvidia-installer command line option.   

*** Unable to determine the target kernel version. ***
So I have to ask: did anything change as far as how nvidia detects the kernel? Even though at the beginning it looks like nvidia already detects the kernel...

I've never had an issue with bumping the ebuild version until this driver. As I said before, 190.42 still emerges fine, so I don't want to hear any "your config is screwed up" replies please
Tonglebeqk is offline   Reply With Quote