View Single Post
Old 11-30-09, 10:20 PM   #43
stevo32
Registered User
 
Join Date: Nov 2009
Posts: 1
Default Re: ArchLinux, xorg 1.7, Nvidia 190.42 => segfault

Using a completely updated fedora 12, I can confirm:

1. The same issue David Ronis had, though I'm now using:

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "1"
EndSection

and it works fine.

2. The segmentation faults many have been reporting using xorg 1.7 and 190.42:
Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e587c]
1: /usr/bin/Xorg (0x8047000+0x5fb66) [0x80a6b66]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0x43e40c]
3: /usr/bin/Xorg (0x8047000+0x108968) [0x814f968]
4: /usr/bin/Xorg (mieqProcessDeviceEvent+0x1c0) [0x80e4d60]
5: /usr/bin/Xorg (mieqProcessInputEvents+0xf0) [0x80e4ea0]
6: /usr/bin/Xorg (ProcessInputEvents+0x18) [0x80b2408]
7: /usr/bin/Xorg (0x8047000+0x26f20) [0x806df20]
8: /usr/bin/Xorg (0x8047000+0x1b8c5) [0x80628c5]
9: /lib/libc.so.6 (__libc_start_main+0xe6) [0xb3abb6]
10: /usr/bin/Xorg (0x8047000+0x1b4b1) [0x80624b1]
Segmentation fault at address 0x4

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

I'm running a completely patched fedora (I'm using xorg-x11-server-Xorg-1.7.1-7.fc12.i686). Applications I had open at the time: thunderbird, firefox, gnome-terminal, xchat, amsn, xmms and the gimp. xccreensaver was probably active, I wasn't at my computer and cannot confirm that.
Attached Files
File Type: gz nvidia-bug-report.log.gz (46.3 KB, 93 views)

Last edited by stevo32; 11-30-09 at 10:38 PM. Reason: attaching bug log
stevo32 is offline   Reply With Quote