View Single Post
Old 12-03-09, 12:31 PM   #5
falolaf
Registered User
 
Join Date: Sep 2004
Posts: 40
Default Re: Geforce G105M Graphics - opensuse 11.1

Hi

I have an Acer Extensa 5635 with a G105M. I have openSuse 11.2, and I had the 6 screens.

I'm using 190.40 driver. With anything higher I have problems with suspend to ram.

The following from xorg.conf fixed the problem. I don't know if its all needed.

Code:
Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
#    InputDevice    "Keyboard0" "CoreKeyboard"
##    InputDevice    "Mouse0" "CorePointer"
#    InputDevice    "TouchPad" "CorePinter"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection
#Section "ServerFlags"
  # Uncomment the following option to reenable kbd/mouse driver input sections. 
  # Otherwise evdev driver is used. 
#  #Option       "AutoAddDevices" "off"
#    Option         "Xinerama" "0"
#    Option	"AIGLX"	"False"
#EndSection

#Section "InputDevice"
#    # generated from default
#    Identifier     "Keyboard0"
#    Driver         "kbd"
#EndSection

#Section "InputDevice"
#    # generated from default
#    Identifier     "Mouse0"
#    Driver         "mouse"
#    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
#    Option         "Emulate3Buttons" "no"
#    Option         "ZAxisMapping" "4 5"
#EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUO"
#    HorizSync       30.0 - 100.0
#    VertRefresh     55.0 - 110.0
    DisplaySize	344 193
#    Mode	"1366x768"
#	DotClock	69.5MHz
#	HTimings	1366 1414 1446 1437
#	VTimings	768 771 775 806
#    EndMode
# Modeline "1366x768"   69.50  1366 1414 1446 1437  768 771 775 806
 Modeline "1366x768"   69.50  1366 1414 1446 1446  768 771 775 806 -hsync -vsync
# Modeline "1366x768q"   72.00  1366 1414 1446 1494  768 771 777 803 -hsync -vsync
#    Option "DPMS" "True"
EndSection

#Section "Device"
#    Identifier     "Configured Video Device"
#    Driver         "nvidia"
#EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce G 105M"
    Option "NvAGP" "0"
#    Option "UseInt10Module" "True"
    Option "UseEDID" "False"
    Option "AllowSHMPixmaps" "True"
    Option "ExactModeTimingsDVI" "True"
    Option "ModeValidation" "NoHorizSyncCheck,NoDFPNativeResolutionCheck,NoExtendedGpuCapabilitiesCheck,NoWidthAlignmentCheck,NoVertRefreshCheck"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    SubSection     "Display"
	Modes	"1366x768"
        Depth       24
    EndSubSection
EndSection
/Anders
falolaf is offline   Reply With Quote