View Single Post
Old 12-07-09, 08:33 PM   #1
Armedblade
Registered User
 
Join Date: Oct 2007
Posts: 23
Default need 1280x1024 resolution, nvidia-auto-select thinks otherwise

Attempts to set 1280x1024 via xorg.conf are ignored and looks like at the end of Xorg.0.log nvidia-auto-select is getting set. Anyway, despite what it says, the resulting res is always 1024x768 and I have to set 1280x1024 manually in nvidia settings after each reboot. I've done the preview option in nvidia-settings and pasted the data into my xorg.conf and still not having any luck. I'm wondering if its acting like this because of the inability to access EDID information.

monitor is Panasonic VIERA TCL37S1 HDTV

Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Tue Oct 20 21:26:01 PDT 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       15.0 - 110.0
    VertRefresh     48.0 - 120.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTS 512"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1280x1024_60 +0+0; 1280x1024 +0+0"
    SubSection     "Display"
        Depth       24
	Modes	   "1280x1024_60+0+0"
    EndSubSection
EndSection
Thanks for any assistance.
Attached Files
File Type: log Xorg.0.log (13.6 KB, 97 views)
Armedblade is offline   Reply With Quote