View Single Post
Old 12-08-09, 05:01 PM   #1
HieronymusJosch
Registered User
 
Join Date: Dec 2009
Posts: 10
Unhappy [Solved] Ubuntu 9.1; geforce2 integrated gpu; nvidia 96.43 SCREEN FREEZES

[Solved] Well, kind of. I ended up buying a GeForce 6200 card and am staring at a big, beautiful 1920x1080 with full desktop effects. I figured it wasn't worth wasting anymore time trying to get an old, slow card with no memory to work on a legacy driver. Versus the 32mb my old card had on hand, I've got a much more respectable 256 and am successfully running the nvidia 190.xx driver! Thanks to all that helped, especially you AaronP!

I have had to install fresh copies of Ubuntu 3 times now to get back to functional GUI. After installing nv 96.43.13 (which is the recommended driver in both Ubuntu's hardware driver console and Envy) and restarting, I am greeted with the following errors:
Code:
[EE]NVIDIA(0) Unable to use default mode "nvidia-auto-select"
[EE}Screen(s) found, but none have a usable configuration
I can then either boot to low graphics for a session, allow nvidia to compile a new configuration, troubleshoot the problem or drop down to the console.

The first two times I've installed the OS and the driver package I opted to allow nvidia to set up a new configuration. Both times proved disasterous. Upon reboot, the screen would freeze at the ubuntu loading screen and become unresponsive. After which, setting the driver in the xorg.conf file to "nv" allowed ubuntu to boot up fully but my lcd read "input not supported." Setting the driver to "vesa" resulted in an unresponsive black screen during the boot up process.

I have saved the existing conf file that is allowing me to use the GUI now as xorg.conf.backup2 just in case. I haven't found much help over at the Ubuntu forums, so I'm heading straight for the graphics gurus over here at nvnews.

I have found a couple of threads here that suggest it may be an issue w/ CPU frequency scaling and that adding the code "exit 0" to /etc/init.d/powernowd resolves the problem. Well, no such file exists on my computer. I also read that adding the option "UseDisplayDevice" "DFP" to the device section of the conf file can solve the problem. Neither did for me.

I did notice that after nvidia tries to build a working configuration, my card information never registers in the conf file like it does in others I've seen. The name of my card, it's busid and such never comes up. Is there a way that I can manually build the correct information into the conf file?

Attached are the current logs. Remember, I'm running in low graphics mode and have yet to configure my device to the new driver; I am concerned that when I do my GUI will be kaput. Any help would be greatly appreciated!

Josch

I ran nvidia-xconfig and rebooted. The screen froze at the ubuntu loading screen, as expected. Here is how the xorg.conf file looks:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Thu Jun 25 18:57:07 PDT 2009


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
As you can see, the geforce2 integrated gpu is not recognized. What gives?
Attached Files
File Type: log :0.log (5.6 KB, 89 views)
File Type: log :01.log (436 Bytes, 90 views)
File Type: log :02.log (5.6 KB, 88 views)
File Type: txt xorg.conf.txt (243 Bytes, 92 views)
File Type: log Xorg.0.log (7.7 KB, 91 views)

Last edited by HieronymusJosch; 12-15-09 at 04:52 PM. Reason: Solved
HieronymusJosch is offline   Reply With Quote