View Single Post
Old 12-11-09, 08:28 PM   #25
amiga_linux
Registered User
 
Join Date: Oct 2009
Posts: 14
Default Re: Which NVIDIA Graphics Cards can display 2048x2048 ?

Hi there,
Hi Bernhard,

I have tested the same issue (i.e. BARCO ISIS MDP-471 with nVidia GeForce 9400 DFI LANParty GF9400-T2RS) with the following configuration.

About my english... please no comment! I give my Best, thanks!
the highest ordered: give never up!

after long one try on the part of Windows (nvidia & powerstrip), I tried it again under linux.

we begins with a new installation of linux. i have try ubuntu 9.10
Install them, make a reboot update the system... but do not install the hardware nvidia drivers from ubuntu.
make a root acount with "sudo passwd root" (it's not necessary)
install with "apt-get install mc" mc (for edit your xorg.conf i like this tool!!!)
now you will download NVIDIA-Linux-x86-190.42-pkg1.run or higher.
Logout your acount and change to a console ttyXY and login with root. (CTRL-ALT-F1)
shutdown the X-Server with "/etc/init.d/gdm stop"
Install the NVIDIA driver as root with "... sh ./NVIDIA-Linux..." and create a new xorg.conf file with the installer.
reboot your system, normaly the screen was change to the nativ resolution of the display.
my first monitor0 (1280x1024 17") is connected to the hdmi port with a divi-d adapter. (to startup the computer, you must deconnected the analogue port DVI-D to Analogue Adapter. after the Bios startup you can connect the BARCO 2K display). Open a console as root, and startup "nvidia-setup"...
with this tool you can activate your 2nd. analogue display. save the xorg.conf file and reboot...
edit your xorg.conf file as root (mc) with thread #9. my xorg.conf looks like that:

************************************************** ************************************************** ************************

#nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder63) Tue Oct 20 21:01:12 PDT 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Tue Oct 20 21:00:15 PDT 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "FUS P17-2"
HorizSync 30.0 - 82.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "BARCO"
ModelName "ISIS"
Option "DPMS"
ModeLine "2048x2048" 257.00 2048 2080 2112 2174 2048 2051 2055 2080
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9400"
BusID "PCI:3:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9400"
BusID "PCI:3:0:0"
Screen 1
Option "DPI" "96 x 96"
Option "UseEDIDFreqs" "FALSE"
Option "UseEDIDDpi" "FALSE"
Option "ModeValidation" "NoEdidModes, NoDFPNativeResolutionCheck, NoVirtualSizeCheck, NoMaxPClkCheck, NoEdidMaxPClkCheck, NoMax$
Option "ExactModeTimingsDVI" "True"
Option "ConnectedMonitor" "DFP"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

#Section "Screen"
# Removed Option "metamodes" "CRT: 1360x768 +0+0"
# Identifier "Screen1"
# Device "Device1"
# Monitor "Monitor1"
# DefaultDepth 24
# Option "TwinView" "0"
# Option "metamodes" "CRT: 800x600 +0+0"
# SubSection "Display"
# Depth 24
# EndSubSection
#EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "2048x2048"
Virtual 2048 2048
EndSubSection
EndSection

************************************************** ************************************************** ************************

logout your acount... now the BARCO Display was comes up... but not 100% perfect.



the wallpapers was scaled in to the screen, so you will see the problem.
now you will see... the Modeline was not perfect. but a GOOD startup

ps: the modline from wyvern666 is the only one it will works a half... with this Modeline, my Barco will Start-Up!!! But only with this!

annyone a idea?

Patrick
Attached Thumbnails
Click image for larger version

Name:	6.jpg
Views:	207
Size:	124.8 KB
ID:	38891  Click image for larger version

Name:	3.jpg
Views:	219
Size:	121.5 KB
ID:	38892  Click image for larger version

Name:	4.jpg
Views:	196
Size:	97.1 KB
ID:	38893  Click image for larger version

Name:	5.jpg
Views:	177
Size:	106.4 KB
ID:	38894  Click image for larger version

Name:	8.jpg
Views:	178
Size:	128.3 KB
ID:	38895  


Last edited by amiga_linux; 12-13-09 at 08:21 AM.
amiga_linux is offline   Reply With Quote