View Single Post
Old 12-13-09, 06:49 PM   #500
mlobo
Lobo
 
Join Date: Dec 2009
Location: Brasil
Posts: 10
Default Re: FreeBSD-amd64 driver ?

Just to report my situation.

Machine:

OS: FreeBSD 8.0-STABLE #0 r198930M: Sat Dec 12 12:49:49 BRT 2009
MB: AOD790GX/128M
VB: nvidia0: <GeForce 9800 GT> on vgapci0
RAM: 8 G
CPU: Phenom 955 black

(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver 195.22 Mon Nov 30 14:03:12 posix/SystemV/PST 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs

X: X.Org X Server 1.6.1
KDE: 4.3.3

My first comment is:
THANK YOU, NVIDIA TEAM ! and also the FreeBSD devel guys for providing the mods that allowed this driver to exist. As you can see by my MB spec, it has an on-board radeon HD 3300, which I unceremoniously dumped and ran out for a GeForce as soon as I saw the driver here. The difference in performance, quality and everything else is enormous.

I've got KDE configured with OpenGL composite enabled and everything runs without a glitch.

The only issue I had so far is with virtualbox. If I enable 3D accel for a guest, the host freezes completly. Only the reset button works. I believe this happens because VBox doesn't know (YET) how to deal with the driver's OpenGL interface.

As a test, I started 7 VMs (4 W2K3s, 2 XPs and 1 Linux) and they all came up fine. I could alt+tab with the flip effect through all of them, get in full screen, get out, turn the desktop cube around, all this with perfect graphics and motion.

Here are the configs I am using:

1) loader.conf
# nvidia
kern.ipc.shmseg="1024"
kern.ipc.shmmni="1024"
kern.ipc.semmns="240"
kern.ipc.semmnu="120"
kern.ipc.semume="40"
kern.ipc.semmni="70"

2) .profile
__GL_YIELD=USLEEP
export __GL_YIELD

3) sysctl.conf
kern.timecounter.hardware=HPET

4) rc.conf
ifconfig_re0="inet 10.10.10.2 netmask 255.255.255.0 polling"

5) xorg.conf
Option "RenderAccel" "on"
Option "DisableGLXRootClipping" "on"
Option "DamageEvents" "on"1) loader.conf
# nvidia
kern.ipc.shmseg="1024"
kern.ipc.shmmni="1024"
kern.ipc.semmns="240"
kern.ipc.semmnu="120"
kern.ipc.semume="40"
kern.ipc.semmni="70"

2) .profile
__GL_YIELD=USLEEP
export __GL_YIELD

3) sysctl.conf
kern.timecounter.hardware=HPET

4) rc.conf
ifconfig_re0="inet 10.10.10.2 netmask 255.255.255.0 polling" <-

5) xorg.conf
Option "RenderAccel" "on"
Option "DamageEvents" "on"

I always was a FreeBSD/nvidia user and this driver truly crowns it all up.

Once again (and again),
Thanks to all that made this possible!
mlobo is offline   Reply With Quote