View Single Post
Old 12-20-09, 07:14 AM   #22
ttsiodras
Registered User
 
Join Date: Dec 2009
Posts: 11
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Same thing happens to me - my card is a GT240/GDDR5 - I realized it after I found out that my GPL CUDA Mandelbrot zoomer run at double speed under Windows (I blogged about it here: http://users.softlab.ece.ntua.gr/~ttsiod/mandelSSE.html )

Code:
bash$ nvidia-settings -q all | grep -A 1 PerfModes
  Attribute 'GPUPerfModes' (home:0.0): perf=0, nvclock=135, memclock=135 ;
  perf=1, nvclock=405, memclock=324 ; perf=2, nvclock=550, memclock=1700 

bash$ nvidia-settings -q all | grep  GPUCurrent | grep Attr
  Attribute 'GPUCurrentClockFreqs' (home:0.0): 405,324.
  Attribute 'GPUCurrentPerfMode' (home:0.0): 1.
  Attribute 'GPUCurrentPerfLevel' (home:0.0): 1.
The level doesn't change no matter what I tried (including setting the registry flags in xorg.conf, to disable powermizer, or hardcode levels...

Code:
Option "RegistryDwords" "PowerMizerEnable=0x0; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"
The bug exists in both 190.53 and 195.22.

Please fix this in the next driver release...

Thanassis Tsiodras, Dr.-Ing.
ttsiodras is offline   Reply With Quote