View Single Post
Old 12-27-09, 10:49 PM   #1
IncubuS
Registered User
 
Join Date: Jun 2008
Location: Russia, Blagoveshchensk
Posts: 10
Default mplayer-vdpau and 195.22

Hello!

Thank you for amd64 drivers! Now I'm trying to use mplayer with VDPAU support on my GT130M. Unfortunately it doesn't work. I've tried latest MPlayer SVN-r30118-4.2.1 and r29354 from ftp://download.nvidia.com/XFree86/vd...789364.tar.bz2. Here is the output:

# ./mplayer -vc ffodivxvdpau ~/Downloads/torrents/Temnij_ritsar_\[torrents.ru].avi
MPlayer SVN-r29354-4.2.1 (C) 2000-2009 MPlayer Team

Playing /home/incubus/Downloads/torrents/Temnij_ritsar_[torrents.ru].avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO: [XVID] 720x304 24bpp 23.976 fps 1060.1 kbps (129.4 kbyte/s)
Clip info:
Software: VirtualDubMod 1.5.10.2 (build 2540/release)
Title: Dark knight 2008
Artist: Petey [torrents.ru]
Genre: Action
Product: Movie
VDPAU capture: Enabled
vdp_imp_device_create_x11(0x8076e4500, 0, -, -)
-> 0, 1, 0x8080072a0
vdp_get_proc_address(1, 0, -)
-> 0, 0x80838e5bc
vdp_get_proc_address(1, 5, -)
-> 0, 0x80838e52e
vdp_get_proc_address(1, 9, -)
-> 0, 0x80839215e
vdp_get_proc_address(1, 10, -)
-> 0, 0x80838e4a0
vdp_get_proc_address(1, 13, -)
-> 0, 0x80839371a
vdp_get_proc_address(1, 22, -)
-> 0, 0x808393368
vdp_get_proc_address(1, 18, -)
-> 0, 0x80839195e
vdp_get_proc_address(1, 19, -)
-> 0, 0x80838e412
vdp_get_proc_address(1, 46, -)
-> 0, 0x8083945a0
vdp_get_proc_address(1, 53, -)
-> 0, 0x80838e260
vdp_get_proc_address(1, 54, -)
-> 0, 0x808393d88
vdp_get_proc_address(1, 47, -)
-> 0, 0x808392aaa
vdp_get_proc_address(1, 48, -)
-> 0, 0x8083942de
vdp_get_proc_address(1, 55, -)
-> 0, 0x80838e1d2
vdp_get_proc_address(1, 56, -)
-> 0, 0x80839066e
vdp_get_proc_address(1, 57, -)
-> 0, 0x80838e144
vdp_get_proc_address(1, 63, -)
-> 0, 0x80838e07a
vdp_get_proc_address(1, 64, -)
-> 0, 0x808390372
vdp_get_proc_address(1, 4096, -)
-> 0, 0x808390104
vdp_get_proc_address(1, 33, -)
-> 0, 0x808394960
vdp_get_proc_address(1, 23, -)
-> 0, 0x8083930c0
vdp_get_proc_address(1, 37, -)
-> 0, 0x808390ebe
vdp_get_proc_address(1, 40, -)
-> 0, 0x808394ad0
vdp_get_proc_address(1, 38, -)
-> 0, 0x80838e2f0
vdp_get_proc_address(1, 26, -)
-> 0, 0x8083914ae
vdp_get_proc_address(1, 27, -)
-> 0, 0x80838e382
vdp_get_proc_address(1, 29, -)
-> 0, 0x808392cd0
vdp_get_proc_address(1, 34, -)
-> 0, 0x8083947f0
vdp_get_proc_address(1, 6, -)
-> 0, 0x80839256e
================================================== ========================
Forced video codec: ffodivxvdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Unsupported PixelFormat -1
Selected video codec: [ffodivxvdpau] vfm: ffmpeg (FFmpeg MPEG-4,DIVX-4/5 (VDPAU))
================================================== ========================
================================================== ========================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 320.0 kbit/20.83% (ratio: 40000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
================================================== ========================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[mpeg4_vdpau @ 0xb649c0]decoding to PIX_FMT_NONE is not supported.
[mpeg4_vdpau @ 0xb649c0]decoding to PIX_FMT_NONE is not supported.
[VD_FFMPEG] Trying pixfmt=0.
Unsupported PixelFormat -1
VDec: vo config request - 720 x 304 (preferred colorspace: MPEG-4 Part 2 VDPAU acceleration)
VDec: using MPEG-4 Part 2 VDPAU acceleration as output csp (no 0)
Movie-Aspect is 2.37:1 - prescaling to correct movie aspect.
VO: [vdpau] 720x304 => 720x304 MPEG-4 Part 2 VDPAU acceleration
vdp_decoder_create(1, 13, 720, 304, 2, -)
VDPAU nvidia: Version: NVIDIA VDPAU Driver Shared Library 195.22 Mon Nov 30 13:59:29 posix/SystemV/PST 2009
VDPAU nvidia: Error detected 0 2998
VDPAU nvidia: Backtrace:
--: /usr/local/lib/vdpau/libvdpau_nvidia.so.1 [0x808000000] DSO load base
00: /usr/local/lib/vdpau/libvdpau_nvidia.so.1 [0x80800c467] vdp_imp_device_create_x11
-> 14
vdp_get_error_string(14)
-> 'An invalid/unsupported VdpDecoderProfile value was supplied.'
[vdpau] Failed creating VDPAU decoder: An invalid/unsupported VdpDecoderProfile value was supplied.
FATAL: Cannot initialize video driver.
Unsupported PixelFormat -1
[mpeg4_vdpau @ 0xb649c0]VDPAU decoding to PIX_FMT_NONE is not supported.
Error while decoding frame!

FATAL: Could not initialize video filters (-vf) or video output (-vo).


Exiting... (End of file)

With "-vc ffodivx" it works without any problems.

# ./mplayer -vo help -vc help | grep vdpau
vdpau VDPAU with X11
ffmpeg12vdpau ffmpeg working FFmpeg MPEG-1/2 (VDPAU) [mpegvideo_vdpau]
ffwmv3vdpau ffmpeg problems FFmpeg WMV3/WMV9 (VDPAU) [wmv3_vdpau]
ffvc1vdpau ffmpeg problems FFmpeg WVC1 (VDPAU) [vc1_vdpau]
ffh264vdpau ffmpeg working FFmpeg H.264 (VDPAU) [h264_vdpau]
ffodivxvdpau ffmpeg working FFmpeg MPEG-4,DIVX-4/5 (VDPAU) [mpeg4_vdpau]

# vdpauinfo
display: :0.0 screen: 0
API version: 1
Information string: NVIDIA VDPAU Driver Shared Library 195.22 Mon Nov 30 13:59:29 posix/SystemV/PST 2009

Video surface:

name width height types
-------------------------------------------
420 4096 4096 NV12 YV12
422 4096 4096 UYVY YUYV

Decoder capabilities:

name level macbs width height
-------------------------------------------
MPEG1 0 8192 2048 2048
MPEG2_SIMPLE 3 8192 2048 2048
MPEG2_MAIN 3 8192 2048 2048
H264_MAIN 41 8192 2048 2048
H264_HIGH 41 8192 2048 2048
VC1_SIMPLE 1 8190 2048 2048
VC1_MAIN 2 8190 2048 2048
VC1_ADVANCED 4 8190 2048 2048

Output surface:

name width height nat types
----------------------------------------------------
B8G8R8A8 8192 8192 y Y8U8V8A8 V8U8Y8A8
R10G10B10A2 8192 8192 y Y8U8V8A8 V8U8Y8A8

Bitmap surface:

name width height
------------------------------
B8G8R8A8 8192 8192
R8G8B8A8 8192 8192
R10G10B10A2 8192 8192
B10G10R10A2 8192 8192
A8 8192 8192

Video mixer:

feature name sup
------------------------------------
DEINTERLACE_TEMPORAL y
DEINTERLACE_TEMPORAL_SPATIAL y
INVERSE_TELECINE y
NOISE_REDUCTION y
SHARPNESS y
LUMA_KEY y
HIGH QUALITY SCALING - L1 -
HIGH QUALITY SCALING - L2 -
HIGH QUALITY SCALING - L3 -
HIGH QUALITY SCALING - L4 -
HIGH QUALITY SCALING - L5 -
HIGH QUALITY SCALING - L6 -
HIGH QUALITY SCALING - L7 -
HIGH QUALITY SCALING - L8 -
HIGH QUALITY SCALING - L9 -

parameter name sup min max
-----------------------------------------------------
VIDEO_SURFACE_WIDTH y 1 4096
VIDEO_SURFACE_HEIGHT y 1 4096
CHROMA_TYPE y
LAYERS y 0 4

attribute name sup min max
-----------------------------------------------------
BACKGROUND_COLOR y
CSC_MATRIX y
NOISE_REDUCTION_LEVEL y 0.00 1.00
SHARPNESS_LEVEL y -1.00 1.00
LUMA_KEY_MIN_LUMA y
LUMA_KEY_MAX_LUMA y
Attached Files
File Type: gz nvidia-bug-report.log.gz (17.3 KB, 143 views)
IncubuS is offline   Reply With Quote