View Single Post
Old 12-29-09, 05:02 AM   #221
stecklum
Registered User
 
Join Date: Feb 2009
Posts: 56
Default Re: VDPAU testing tool

Hi, version 0.3 worked fine

qvdpautest-0.3$ ./qvdpautest
Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz
10:42 NVIDIA(0): NVIDIA GPU GeForce 8400M GS (G86M) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library 195.30 Fri Dec 18 17:11:08 PST 2009

SURFACE GET BITS: 843.48 M/s
SURFACE PUT BITS: 882.436 M/s

MPEG DECODING (1920x1080): 62 frames/s
MPEG DECODING (1280x720): 136 frames/s
H264Decoder: FATAL: Can't create required surfaces!!
Can't initialize H264 decoder!H264 DECODING (1280x720): 86 frames/s
VC1 DECODING (1440x1080): 100 frames/s

MIXER WEAVE (1920x1080): 311 frames/s
MIXER BOB (1920x1080): 434 fields/s
MIXER TEMPORAL (1920x1080): 95 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 131 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 33 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 36 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 123 fields/s

but 0.4 gives mixer errors

qvdpautest$ ./qvdpautest
Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz
NVIDIA GPU GeForce 8400M GS (G86M) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library 195.30 Fri Dec 18 17:11:08 PST 2009

SURFACE GET BITS: 763.33 M/s
SURFACE PUT BITS: 875.129 M/s

MPEG DECODING (1920x1080): 62 frames/s
MPEG DECODING (1280x720): 136 frames/s
H264Decoder: FATAL: Can't create required surfaces!!
Can't initialize H264 decoder!H264 DECODING (1280x720): 86 frames/s
VC1 DECODING (1440x1080): 101 frames/s

FATAL: Can't create mixer output surface !!
FATAL: Can't create mixer output surface !!
stecklum is offline   Reply With Quote