View Single Post
Old 10-16-03, 12:45 PM   #1
rs-pcv
Registered User
 
Join Date: Oct 2003
Posts: 3
Default nvidia kernel 4496 in 2.4.21 kernel problems

I have the following:-
Sony Vaio RS series PVC-RS226
Pentium 4 2.8G wi Intel chipset 865pe (ASUS?)
GeForce 5200 128 mb (onboard)
Onboard sound
Sony display SDM-HS53 (though not an issue)

Redhat 9.1 with alternative kernels in Grub including 2.4.20-20.9smp and 2.4.21-20.1.2024.2.1.nptlsmp.
Having compiled in the headers etc. for nvidia kernel 4496 all works, though there are a few slips for the unwary.
However sound does not work for this board with this kernel. Research tells me that it only works with a 2.4.21+ kernel. I have patched the kernel and sound does work.
The problem then is to bring back up the nvidia support.
Following the logic of the drivers page directs one to the NVIDIA_kernel-1.0-4050 driver (although supported cards do *not* include GF 5200).
If I try to compile this into the new kernel it aborts with a complaint about the -m flag values being out of range. So I cannot comile that driver into that linux kernel.
If I compile in the 4496 kernel to that linux kernel this seems to go OK but when I start X that process aborts with a signal 11 and I don't believe much of anything else helpful. (This is not in the attached log file. I have looked for it but I think I would have to regenerate it doing all of the above.)
What to do?
Attached Files
File Type: log xfree86.0.log (0, 127 views)
rs-pcv is offline   Reply With Quote