View Single Post
Old 01-05-10, 09:32 PM   #3
IncubuS
Registered User
 
Join Date: Jun 2008
Location: Russia, Blagoveshchensk
Posts: 10
Default Re: mplayer-vdpau and 195.22

Quote:
Originally Posted by hl_ View Post
Your GPU only supports VDPAU feature set A (see the README for more information). Feature set A does not support DivX/XViD decode acceleration, i.e. ffodivxvdpau doesn't work. OTOH these codecs have modest requirements, so usually acceleration isn't needed even on slow CPUs. Try something with H.264 or VC-1 instead.
You are right:

...
VIDEO: [avc1] 1280x544 24bpp 24.000 fps 0.0 kbps ( 0.0 kbyte/s)
================================================== ========================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat -1
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
================================================== ========================
================================================== ========================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))
================================================== ========================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] Trying pixfmt=0.
Unsupported PixelFormat -1
Movie-Aspect is 2.35:1 - prescaling to correct movie aspect.
VO: [vdpau] 1280x544 => 1280x544 H.264 VDPAU acceleration
[VD_FFMPEG] XVMC-accelerated MPEG-2.
A: 4.3 V: 4.3 A-V: -0.005 ct: 0.022 0/ 0 6% 3% 5.6% 6 0

It works! Thanks!
IncubuS is offline   Reply With Quote