View Single Post
Old 10-17-03, 03:31 AM   #10
TheOneKEA
Fifteen-K Saiyan Bastard
 
TheOneKEA's Avatar
 
Join Date: Aug 2002
Location: Somewhere in England, waiting for ROTK and drooling over the A64 3000+
Posts: 417
Send a message via ICQ to TheOneKEA Send a message via AIM to TheOneKEA Send a message via Yahoo to TheOneKEA
Default

Quote:
Originally posted by JeffShultz
I've got those drivers. I've also got some very weird errors (that occurred under Mdk 9.1 and 9.2RC1).

Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: unsupported bridge
agpgart: no supported devices found.

Basically Linux isn't finding my AGP slot. I assume there is a reason that there is some sort of GART patch in the nForce drivers.
Does this file exist?

/lib/modules/`uname -r`/kernel/drivers/char/agp/agpgart.o

If it does, then edit /etc/modules.conf and add the following line:

options agpgart agp_try_unsupported=1

Close down any open X applications, then type Ctrl-Alt-F2 to switch to virtual console 2, log in as root, then shut down X with the following command (if you use graphical logins):

# init 3

Once X is shut down, type the following commands into the console:

# /sbin/modprobe -r agpgart
# /sbin/modprobe agpgart

Check your dmesg for lines like this:

Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected an Intel i845 Chipset.
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: AGP aperture is 64M @ 0xec000000

If you get those lines, the AGP GART driver found your AGP bridge. Restart X by typing:

# init 5 && logout

You may need to edit your XF86Config to use the proper drivers once you get agpgart working.
__________________
/me \/\/@|\|t5 $$$$$ F0r @|\| u65r 3|33t G@/\/\1|\|G r1G

SCREW THE ADS! http://adblock.mozdev.org/
Proud user of teh Fox of Fire - Mozilla Firefox 0.8

Registered Linux User #289618
TheOneKEA is offline   Reply With Quote