View Single Post
Old 01-09-10, 05:04 AM   #1
romain8540
Registered User
 
Join Date: Jan 2010
Posts: 2
Default 9650M GT / FreeBSD 8.0 / 195.22beta / amd64

Hello,

I have a 9650M GT on an Asus M70Vn laptop.

This card on this laptop is known to crash X (in my case the whole system) with the official nVidia drivers later than 173, under Linux (and FreeBSD)

In order to have my graphic card working under linux, I have to load the module with option NVreg_RegistryDwords="PerfLevelSrc=0x2222" wich forces "Performance Mode" for PowerMizer. It works fine with debian packaged 190.42 nVidia non-free driver

Under FreeBSD, it seems that I have to use the sysctl hw.nvidia.registry.dwords, but setting it to "PerfLevelSrc=0x2222" doesn't force performance mode.
Setting it manually whit nvidia-settings at starting X works (my system doesn't crash anymore), so it's the right workaround.
How can I force Performance Mode? (either using sysctl or any other way?)

BTW: All my OSes are amd64, if it matters

Thanks in advance,
Romain

Last edited by romain8540; 01-09-10 at 10:03 AM. Reason: Debian version was 190.42, not 195.42
romain8540 is offline   Reply With Quote