View Single Post
Old 10-17-03, 11:16 AM   #1
Plaz McMan
Registered User
 
Join Date: Oct 2003
Location: Gualala, CA
Posts: 13
Default FX 5200 and RH9 problems

--------------------------------
PNY Verto GeForce FX 5200 (AGP)
nForce-2 mobo (Epox)
Athlon 1800+
--------------------------------

I recently installed RH9, and can succesfully boot into Xwindows, using my driver as "nv."
However, I would like to be able to use "nvidia" as my driver, but it does not seem to be working. I installed the nForce drivers and the display drivers, but still, no luck. I modified my XF86Config file as specified in the readme. When I try startx, the screen goes black (but does not turn off), and the machine freezes (no keybord LEDs, and CTRL ALT DEL doesn't work). I think I had it all working once (saw spalsh screen), though I forgot what I did (and, stupidly, forgot to backup my Config file).

My WORKING config file, with "nv". I tried replacing "nv" with "nvidia", but it locks up. Any suggestions? Also, I have no problems with re-installing the whole system, if that would make it easier for a walkthrough.



# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "dvorak"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Gateway Vivitron 20"
HorizSync 29.0 - 82.0
VertRefresh 50.0 - 150.0
Option "dpms"
EndSection

Section "Device"
Identifier "nvidia0"
Driver "nv"
BoardName "Unknown video card"
EndSection

Section "Screen"
Identifier "Screen0"
Device "nvidia0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection



#Thanks,

#Brannon
Plaz McMan is offline   Reply With Quote