View Single Post
Old 01-11-10, 05:39 PM   #1
hfourxzeror
Registered User
 
Join Date: Jan 2010
Posts: 3
Exclamation Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Good afternoon everyone!

Recently, I purchased a Nvidia GeForce GT 220 for my HTPC (Dell Optiplex GX280).
I was looking forward to the HD and accelerated graphics with my Visio 52' LCD.

I formatted the hdd and installed a fresh version of Ubuntu 9.10. I installed all the updates for Linux. Then I went to the Nvidia website and downloaded the latest set of drivers (version 190.53). I installed the drivers and rebooted. Everything seemed great! The picture quality was amazing and the video was smooth.

But there was a problem, no audio! I'm getting no audio from HDMI.

I did some research around online to find a solution or a hack. But nothing worthwhile. I've searched this forum also with no luck. I did find lots of threads on "audio over hdmi", but nothing that helped me! Or the thread was several years old and outdated.

I then sent Nvidia a ticket asking if the GeForce GT 220 even worked with Linux and audio over HDMI. From there, they sent me the HD_AUDIO-9.10.tar.gz (see attached file).

I figured that I just needed to compile it and the audio would work! So, I did so.

After compiling it and stuff, I rebooted. Upon reboot there is still no audio....
I've checked alsamixer to see if it was muted, but I unmuted everything.

Help me out guys! If you need me to post any outputs from the terminal, I'd be MORE than happy to do so!

Thanks so much!
Please help me out!

-Dale
Attached Files
File Type: gz HD_AUDIO-9.10.tar.gz (93.2 KB, 892 views)

Last edited by hfourxzeror; 01-11-10 at 05:40 PM. Reason: grammar
hfourxzeror is offline   Reply With Quote