View Single Post
Old 02-05-10, 01:54 AM   #2
Almighty1
Registered User
 
Almighty1's Avatar
 
Join Date: Feb 2010
Location: San Francisco, California USA
Posts: 4
Send a message via ICQ to Almighty1 Send a message via AIM to Almighty1 Send a message via MSN to Almighty1 Send a message via Yahoo to Almighty1
Default Re: new legacy releases for FreeBSD-8.0 needed

What's the correct procedure to get 96.43 to compile under FreeBSD 8.0-RELEASE or 9.0-CURRENT? This is where it errors:

cc -O2 -pipe -DNV_VERSION_STRING=\"96.43.14\" -D__KERNEL__ -DNVRM -UDEBUG -U_DEBUG -DNDEBUG -O -fno-strict-aliasing -Werror -D_KERNEL -DKLD_MODULE -nostdinc -I/src -I. -I@ -I@/contrib/altq -finline-limit=8000 --param inline-unit-growth=100 --param large-function-growth=1000 -fno-common -mno-align-long-strings -mpreferred-stack-boundary=2 -mno-mmx -mno-3dnow -mno-sse -mno-sse2 -mno-sse3 -ffreestanding -fstack-protector -std=iso9899:1999 -fstack-protector -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual -Wundef -Wno-pointer-sign -fformat-extensions -c nvidia_dev.c
nvidia_dev.c:138: error: conflicting types for 'nvidia_dev_mmap'
nvidia_dev.c:20: error: previous declaration of 'nvidia_dev_mmap' was here
*** Error code 1

Stop in /boot/modules/NVIDIA-FreeBSD-x86-96.43.14/src.
*** Error code 1

Stop in /boot/modules/NVIDIA-FreeBSD-x86-96.43.14.
__________________
Cheers,
Vince
Almighty1 is offline   Reply With Quote