View Single Post
Old 02-17-10, 10:55 AM   #14
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Hi doogs,
Glad you got audio working on hdmi.

I have a gt210 running ubuntu 9.10 and alsa 1.0.22, 195.22 nvidia driver with the alsa nvidia patch installed based on your how-to (well written and easy to follow, thanks!). But no audio over hdmi when running a test with aplay. Appreciate any inputs on what I maybe missing.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

I unmuted the SPDIF for card 1 (nvidia hdmi one) using alsamixer.

───────────────────────────── AlsaMixer v1.0.22 ──────────────────────────────┐
│ Card: HDA NVidia F1: Help │
│ Chip: Nvidia NVIDIA G210 HDMI F2: System information │
│ View: F3:[Playback] F4: Capture F5: All F6: Select sound card │
│ Item: S/PDIF Esc: Exit │
│ │

│ ┌──┐ │
│ │OO│ │
│ └──┘ │
│ < S/PDIF > │
│ │


Tested with aplay as follows.

Tried the default audio output and works.

$ aplay -Dplughw:0,0 /usr/share/sounds/alsa/Rear_Right.wav

Hear audio on my speakers.

The hdmi is connected to my panasonic tv and the audio is turned on. Video runs ok. Tried running hdmi audio as follows but no audio.

$ aplay -Dplughw:1,3 /usr/share/sounds/alsa/Rear_Right.wav

After checking in other postings, have added these into my asound.conf and sound.conf.

$ cat /etc/asound.conf
pcm.!default {
type hw
card 1
device 3
}

$ cat /etc/modprobe.d/sound.conf
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

Am I missing something in my setup?

I notice zim2dive and alanw's postings (Jan 12, Jan 13, 2010) indicating that nvidia driver may not support audio over hdmi. This confuses me. Did something change on the nvidia drivers since then?
rp_linux is offline   Reply With Quote