View Single Post
Old 02-23-10, 02:27 PM   #20
rp_linux
Registered User
 
Join Date: Jan 2010
Posts: 15
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

I tried playing with the /etc/modprobe.d/sound.conf. hdmi audio did not work in any of those combinations. Iam posting the dmesg and aplay info, hoping someone can point out what maybe wrong in my setup.

Trial 1: With this line in sound.conf
"options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2"

Both cards are recognized however dmesg shows some errors.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

$ dmesg | grep hda
[ 16.250616] hda_intel: codec_mask forced to 0xff
[ 17.296009] ALSA hda_intel.c:695: azx_get_response timeout, switching to polling mode: last cmd=0x000f0000
[ 18.300018] ALSA hda_intel.c:1397: Codec #0 probe error; disabling it...
[ 19.392234] ALSA hda_intel.c:1397: Codec #1 probe error; disabling it...
[ 20.432012] ALSA hda_intel.c:1397: Codec #3 probe error; disabling it...
[ 20.505135] hda_codec: ALC888: BIOS auto-probing.
[ 20.511242] hda_intel: codec_mask forced to 0xf2
[ 30.290445] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.


Trial 2: With this line in sound.conf
"options snd-hda-intel enable_msi=0"

dmesg doesn't show errors atleast.

$ dmesg | grep hda
[ 9.701302] hda_codec: ALC888: BIOS auto-probing.
[ 10.416091] ALSA hda_intel.c:1971: Invalid PCM device number 8
[ 10.416098] hda_codec: cannot attach PCM stream 8 for codec #2
[ 10.432051] ALSA hda_intel.c:1971: Invalid PCM device number 9
[ 10.432058] hda_codec: cannot attach PCM stream 9 for codec #3
[ 33.268937] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.


Trial 3: With this line
options snd-hda-intel enable_msi=0 index=-2


dmesg is clean

$ dmesg | grep hda
[ 16.172994] hda_codec: ALC888: BIOS auto-probing.
[ 17.094058] ALSA hda_intel.c:1971: Invalid PCM device number 8
[ 17.094062] hda_codec: cannot attach PCM stream 8 for codec #2
[ 17.112033] ALSA hda_intel.c:1971: Invalid PCM device number 9
[ 17.112038] hda_codec: cannot attach PCM stream 9 for codec #3
[ 28.711242] hda-intel: IRQ timing workaround is activated for card #0. Sugges


$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

Still no sound in hdmi.
rp_linux is offline   Reply With Quote