View Single Post
Old 02-23-10, 02:32 PM   #21
Rodercot
Registered User
 
Join Date: Feb 2010
Location: Ottawa, Canada
Posts: 12
Default Re: Nvidia GeForce GT 220 + Ubuntu 9.10 = No audio over HDMI?

Quote:
Originally Posted by rp_linux View Post
Rodercot - Thanks for your pointers and encouraged to hear your GT240 is working great!

I did setup my alsa 1.0.22 using paoleary's patch and following his write up (thanks to paoleary for putting this together).

http://wiki.xbmc.org/?title=HOW-TO_s...20%2C_or_GT240

One difference I can see between our setups is, I haven't disabled the onboard audio. I have hesitated to do so as it is the only working audio output I got but maybe worth a try.

Can you please point me how to do it. Should I disable it in bios or is there a simpler way to do it?

Is ion chipset same as GT210 (sorry, not familiar with ion)?

Do you see anything else that might be wrong in my setup?

Reading some other postings, I have heard mixed responses on what to enter in /etc/modprobe.d/sound.conf.

I have tried several combinations but no hdmi sound still. My nvidia card is card1.


options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

Gave some errors in dmesg with the probe_mask. Removing the probe_mask gets rid of the dmesg errors but no hdmi output.

Tried this also but no luck.
options snd-hda-intel enable_msi=0 index=1

I don't know if these make a difference for GT210. Can you post your working sound.conf?

If anyone has a working (from hdmi audio perspective) sound.conf for GT210, can you please post it.

Hi rp_linux,

you are not alone, there seems to be several who cannot get the 210 cards to output hdmi. Not sure if you posted but what type of card is it. The other one I see is MSI, on another note - Is there anyone that has audio working on there 210 card.

as for the on-board sound, in the bios under integrated devices I think it was; I just disabled the audio and then under chipset - southbridge I think you should have an option for disabling on-board gpu if ext gpu is present and then I disabled the buffer this then allows you to allocate some shared memory to the card via the box below it, I set this at 512 - not even sure if the new cards need this any longer. This is if you have on-board video of-course. Ion is just a 9300/9400M chipset if I recall.

My sound.conf file is simply

options snd-hda-intel enable_msi=0 probe_mask=0xfff2

This is because I have disabled my on-board sound card making the nvidia hdmi card 0 and no longer card 1 so I do not need the first 0xffff. I could be wrong but I am sure that some had there cards working prior to adding the msi=0 option - you may want to try without that option just too test it. Also if you disable the on-board sound card your dmesg errors will go away at least they do for me, you will still see the probing but no errors.

Regards,

Dave
Rodercot is offline   Reply With Quote