View Single Post
Old 04-26-10, 10:01 PM   #22
tvynr
Registered User
 
Join Date: Apr 2010
Posts: 1
Default Re: Monitor won't go to sleep properly with 9500GT

+1 for this! Just fixed the GeForce 210 I recently bought to replace a GeForce 7300. The 7300 didn't have this problem but the 210 did. For those curious, here are the steps I used:

1. Use nvidia-settings to extract the EDIDs for the monitor. (Acquire EDID button in the section about your monitor under GPU N.)
2. Open nvidia-settings using your favorite hex editor.
3. In position 0x18 (decimal position 24), you will likely find that the first three bits of the value there are zero. (Mine was 0x0a.) Change them to ones. (In my case, 0xea.)
4. Save the edid.bin somewhere like /etc/X11/fixed-edid.bin
5. Add the following to the Devices section of your /etc/X11/xorg.conf:

Code:
Option         "CustomEDID" "/etc/X11/fixed-edid.bin"
Restart your X server and everything should be go. Wikipedia has a good reference on the EDID binary format here: http://en.wikipedia.org/wiki/EDID

Warning: if you don't understand any of the steps above, learn about things like hex editing and binary before you try to execute them. I have no idea what would happen if you forced the driver to use a messed up EDID binary.

Thanks again!
tvynr is offline   Reply With Quote