View Single Post
Old 05-15-10, 09:52 AM   #27
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: Enable audio through HDMI on GT240

Quote:
Originally Posted by paoleary View Post
If you've got the four devices listed, you can knock that down to a single one with the probe_mask setting in /etc/modprobe.d/sound.conf as described on the XBMC wiki. (I pretty much wrote it, collecting the knowledge from the XBMC forum thread before it got wiped, so if it's unclear somewhere, my apologies--edits/suggestions are appreciated.)
LOL, apologies are not required... you have my thanks for getting me much further than I would have otherwise. My take on things was that I had a card not yet covered by the possible cases... Ihad so many things break in my 9.10 to 10.04 upgrade that this is just a side experiment for now.

I've tried 5 possible modprobe settings now...

- nothing
- enable_msi=0 probe_mask=0xffff,0xfff2
- enable_msi=0

these give me the 4 copies at device 1 (3,7,8,9)

- options snd-hda-intel enable_msi=0 index=-2
- options snd-hda-intel enable_msi=0 index=1

These 2 give me the same 4 options but listed as being card 0.. .and the sound pref panel won't come up.. it says "waiting for sound system to start" (or something like that)

For asound.conf I am still using
Quote:
pcm.!default {
type hw
card 1
device 7
}
I tried reading your link to http://www.kernel.org/pub/linux/kern...robing_problem to remove the duplicate nvidia entries, but I'm in over my head at this point, and/or just blind. (this was the page I was referring to where I had hoped to find more spaghetti to throw )

thanks!
zim2dive is offline   Reply With Quote