View Single Post
Old 05-16-10, 01:23 PM   #29
paoleary
Registered User
 
Join Date: Feb 2010
Posts: 37
Default Re: Enable audio through HDMI on GT240

Oh, man, you went to 10.4...you're a better man than I. The latest kernel update on 9.10 broke my audio. I just backed out the change (technically, set the default boot option to "2" instead of "0" in /etc/grub/menu.lst) rather than try to crawl through that mess.

I'd drop the asound.conf you have in favor of the one in the wiki. It avoids explicitly numbering devices/codecs, so it should be more reliable, and will make the HDMI out ALSA:default (useful with applications that don't let you set a specific ALSA device, like snes9x-gtk ).

I'm not sure about the index=yy options for modprobe; those were suggested by someone else but I haven't used them since the NVidia device comes up on the same card # consistently on my box (and actually, I've now disabled the onboard for Ultimate Consistency).

I've never checked if system sounds worked, since if they did, I'd want them to be silent as the machine spends the vast majority of its time in either mythfrontend or snes9x-gtk, and I wouldn't want to hear them anyways.
paoleary is offline   Reply With Quote