View Single Post
Old 05-17-10, 05:02 PM   #33
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: Enable audio through HDMI on GT240

Quote:
Originally Posted by zim2dive View Post
Made _some_ progress.

In XBMC, I was able to set a "custom" audio output device, as "plughw:1,7", exit, relaunch XBMC and I have sound now.

Working: mplayer, xbmc, flash

not working : ryhthmbox, system sounds

I launched gstreamer-properites and set its audio output to my 2nd HDMI entry (out of 4) (shows up as 1,7 in the shaded out comments), but that didn't seem to help rhythmbox.
Ok, moving sideways
Code:
>more /etc/modprobe.d/sound.conf 
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2
at this point, I have working sound from 1,3... and I have sound from Rhythmbox.. the Sound preference panel refuses to launch. So does the Pulseaudio sound panel, they used to launch. I'm using
Code:
pcm.!default hdmi:NVidia
pcm:iec958 hdmi:NVidia
EDIT: Flash sound ok after all.
EDIT2: I got Sound panel and Pulseaudio volume working. .I had to edit /etc/pulse/default.pa and comment out the line
Code:
load-module module-alsa-sink device=hw:1,3
Now I can launch the panel and get system sounds out HDMI. Need to go back and test everything else (will be tomorrow).

Working: *maybe* everything
zim2dive is offline   Reply With Quote