View Single Post
Old 05-22-10, 04:59 PM   #20
GPL Is Still King
iron99's Avatar
Join Date: Oct 2004
Posts: 181
Default Re: Original F.E.A.R. on Steam!

Originally Posted by Sazar View Post
Ok, I think I found a fix. Worked for me at least.

I'll sum it up.

Go to Device Manager.

Expand Human Interface Devices.

Go to PROPERTIES for each of these devices and go to the Details Tab. In the Drop Down, select Hardware ID's.

For each Human Interface Device, anything with the following information for Hardware ID (HID\Vid_046d&Pid_c041&), disable that.


I had 3 items, I disabled them and went from 100% below the lowest level (20FPS?) to 100% over 60 FPS.

Note, I am playing with all my G-devices currently connected and I ran the benchmark with my Auslogics Defrag running in defrag+optimize mode in the background.

Definitely a nice improvement.

Running 100% maxed @ 1920x1200.
Thanks for the lead!

For me these were the problem Human Interface Devices -

Device 1 -


Device 2 -


With one or the other enabled FPS go down to 35, with both enabled FPS go down to 16.

With these two devices disabled all is fine in FEAR for me running the G15 and MX518.
AMD Phenom 1090T @ 3.8 On H2O\ Asus M4A89TD Pro/USB3.0\CORSAIR XMS3 8GB\RealSSD C300 128GB SataIII (OS)2xWD 600 GB(1 Apps. and Games/1 My Docs)WD 1.5TB for backup\ 480 GTX @825/2000/1.113V on H2O\Dell 2405\350Watt 5.1 Sound\1000watt single rail PSU\Logitech MX518 and G15 / ECCI Trackstar 6000 / Frex H-Shifter+\Windows 7 Professional 64-bit\My Favorite games - FallOut 3 with PFEE Mod
iron99 is offline   Reply With Quote