View Single Post
Old 05-23-10, 11:05 AM   #1
BoscoBearbank
Registered User
 
Join Date: Sep 2009
Posts: 8
Question Failed compile with Fedora kernel-2.6.34-11.fc14.x86_64

Using NVIDIA-Linux-x86_64-256.25.run (but also tried NVIDIA-Linux-x86_64-195.36.24-pkg2.run with the same result) with Fedora Rawhide. No problem compiling with kernel-2.6.34-0.28.rc3.git3.fc14.x86_64; failure with kernel-2.6.34-11.fc14.x86_64 (GPL-incompatible module nvidia.ko uses GPL-only symbol 'debug_lockdep_rcu_enabled'). nvidia-installer.log file is attached.

Can someone point me to a simple way to find the code that needs to be modified to work around GPL-only symbol errors such as these? Otherwise, all I can do is wait for someone else to deal with the problem.

Thanks
Attached Files
File Type: log nvidia-installer.log (24.9 KB, 97 views)

Last edited by BoscoBearbank; 05-23-10 at 11:06 AM. Reason: add attachment
BoscoBearbank is offline   Reply With Quote