View Single Post
Old 05-26-10, 05:52 AM   #43
fuzzy2010
Registered User
 
Join Date: May 2010
Posts: 4
Default Re: Enable audio through HDMI on GT240

I am still having problems with my Asus GT 220. Mythdora 12.23 (Fedora 12). There's quite some confusion on my part what should be correct sound.conf for me.

uname -a
Code:
Linux localhost.localdomain 2.6.32.12-115.fc12.x86_64 #1 SMP Fri Apr 30 19:46:25 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
lspci -v
Code:
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
        Subsystem: Giga-byte Technology Device a002
 01:00.0 VGA compatible controller: nVidia Corporation Device 0a20 (rev a2) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 830f
 01:00.1 Audio device: nVidia Corporation Device 0be2 (rev a1)
        Subsystem: ASUSTeK Computer Inc. Device 830f
Code:
rpm -qa|grep alsa
alsa-utils-1.0.22-1.fc12.x86_64
alsa-lib-1.0.23-1.fc12.x86_64
alsa-kmdl-2.6.32.12-115.fc12-1.0.23-83.fc12.x86_64

rpm -qa|grep nv
libgnomecanvas-2.26.0-2.fc12.x86_64
nvidia-xconfig-1.0-2.fc12.x86_64
kmod-nvidia-2.6.32.12-115.fc12.x86_64-195.36.24-1.fc12.2.x86_64
nvidia-settings-1.0-3.4.fc12.x86_64
xorg-x11-drv-nv-2.1.15-2.fc12.x86_64
kmod-nvidia-195.36.24-1.fc12.2.x86_64
gnome-python2-canvas-2.28.0-1.fc12.x86_64
xorg-x11-drv-nvidia-libs-195.36.24-1.fc12.x86_64
kmod-nvidia-2.6.32.11-99.fc12.x86_64-195.36.15-1.fc12.2.x86_64
xorg-x11-drv-nvidia-195.36.24-1.fc12.x86_64
cat /etc/modprobe.d/sound.conf

Code:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2
#options snd-hda-intel enable_msi=0 probe_mask=0xfff2
aplay -l

Code:
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
cat /etc/modprobe.d/alsa-dist.conf

Code:
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-seq
cat /etc/asound.conf

Code:
#
# Place your global alsa-lib configuration here...
#

@hooks [
        {
                func load
                files [
                        "/etc/alsa/pulse-default.conf"
                ]
                errors false
        }
]

pcm.!default hdmi:NVidia
pcm:iec958 hdmi:NVidia
/etc/alsa/pulse-default.conf does not exist. There is a alsa-ctl.conf in there.

cat /etc/alsa/alsactl.conf
Code:
#
# ALSA library configuration file for alsactl tool
# (/usr/share/alsa tree is not necessary for alsactl)
#

ctl.hw {
        @args [ CARD ]
        @args.CARD {
                type string
                default "0"
        }
        type hw
        card $CARD
}

cat /etc/pulse/default.pa
Code:
load-module module-alsa-sink device=hw:1,3
Again, when doing the various speaker tests I don't get errors, but no sound. I have to umute the spdif on the hdmi every time, so I didn't forget that ever.

No sound:
Code:
aplay -D plughw:1,3 Noise.wav
Playing WAVE 'Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Sound:
Code:
[root@localhost alsa]# aplay -D plughw:0,0 Noise.wav
Playing WAVE 'Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
fuzzy2010 is offline   Reply With Quote