View Single Post
Old 05-26-10, 03:04 PM   #11
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: GT 330M Driver problems

The "unable to load module" one?

Are you absolutely sure you blacklisted nouveau&co and then rebooted?

Also, there is a thing called KMS - that should be deactivated too.
You have to append "nomodeset" to your kernel boot parameters.
If you are using Grub loader, edit the /boot/grub/menu.lst file:

sudo gedit /boot/grub/menu.lst

find the default boot entry (the upper one that appears in the boot options)

The entry contains a few lines beginning with title, root, kernel, initrd.
You need to edit the kernel line, appending to the end of it "nomodeset" without the quotes - make sure that it has a space between the previous option and the nomodeset.

If there is no menu.lst, you have the Grub2 loader. Edit the /etc/default/grub file:

sudo gedit /etc/default/grub

look for GRUB_CMDLINE_LINUX_DEFAULT, append to the existing options "nomodeset" withouth the quotes - leave spece between it and the rest of the options.

Reboot, repeat the rest of the procedure.
gradinaruvasile is offline   Reply With Quote