View Single Post
Old 05-26-10, 05:35 PM   #45
fuzzy2010
Registered User
 
Join Date: May 2010
Posts: 4
Default Re: Enable audio through HDMI on GT240

Quote:
Originally Posted by paoleary View Post
@fuzzy2010: Kill the @hooks[] section of /etc/asound.conf and kill /etc/alsa/alsactl.conf completely. For good measure, kill the alias lines in /etc/modprobe.d/sound.conf too. Your probe_mask is right; enable_msi is technically not needed anymore but it doesn't hurt. (Of course, make backups of these files!)

Check the output from `lsmod | grep snd'. If snd_hda_codec_nvhdmi isn't loaded, I don't think you'd even see the device, but check anyway. If not loaded, you'll need to load it.
ok, commented out all the hook section. Moved the alsactl.conf to alsa.conf.bak. My sound.conf:

Code:
#options snd-hda-intel enable_msi=0 probe_mask=0xfff2

#alias snd-card-0 snd-hda-intel
#alias sound-slot-0 snd-hda-intel

options snd_hda_codec_nvhdmi

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2
#options snd-hda-intel enable_msi=0 probe_mask=0xfff2

lsmod|grep snd_hda_codec_nvhdmi
snd_hda_codec_nvhdmi 12743 1
snd_hda_codec 83951 3 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda _intel
snd 60294 9 snd_hda_codec_nvhdmi,snd_hda_codec_realtek,snd_hda _intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_dev ice,snd_pcm,snd_timer

unmuted in alsamixer the nvidia spdif.

Still no sound. I notice if I am watching something in MythTv and try aplay:

aplay -D plughw:1,3 Noise.wav
aplay: main:608: audio open error: Device or resource busy

Also, this produces no sound now:

aplay -D plughw:0,0 Noise.wav
Playing WAVE 'Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
fuzzy2010 is offline   Reply With Quote