View Single Post
Old 05-28-10, 01:06 PM   #521
NarcissistZero
Loving Everything Me
 
NarcissistZero's Avatar
 
Join Date: Jun 2007
Location: Tampa, FL
Posts: 8,033
Send a message via AIM to NarcissistZero
Default Re: Official "I just got a Geforce GTX 470/480/465" thread

Quote:
Originally Posted by nekrosoft13 View Post
driver problems? AA problems? or other typical ATi problems?

What case you got? fan setup? room temp? pics?
The 5870 is just not boosting my frames at all in most games... GTA4 actually runs significantly worse. The only game I tested last night and today that gave me a significant increase in performance was Bad Company 2, which somehow got a 20fps boost. Nothing else came at all close to that, and $420 to run one game better is insane.

On top of that the profiles on ATI are annoying and both Metro 2033 and Borderlands would suddenly not load up at all, which googling tells me is an issue with their Physx needs and some ATI drivers.

It's just a cluster-f**k all around really, and exactly what I feared when I was thinking of going ATI because of all the good reviews.

So I am planning to return it tomorrow and either get a second GTX 275 and join the world of SLI, or spend too much money and get a 480. Or neither and get a PS3 or Wii... hahaha.

I have a nice Antec tower case with 4 fans on it that keeps things nice and cool. Room temp is always 75 degrees.
__________________
I gots one of them high powered gaming computers with an EVGA GTX 480 video thingy and a Q9550 processing device and also one of them Windows 7 64 operating programs with 4GB of some Corsair 1033 DDR2 ram.

Steam, Xbox Live and PSN: StingingVelvet
NarcissistZero is offline   Reply With Quote