View Single Post
Old 06-04-10, 04:46 PM   #8
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: insmod: error inserting './usr/src/nv/nvidia.ko and can't find my NVIDIA card?

Quote:
Originally Posted by ant View Post
I can't even remove it:
You can't remove it because it's done the KMS. I'll explain below.

Quote:
What is KMS? And where do I add "nouveau.modeset=0" to my kernel boot? I have never done this before.
KMS is Kernel Mode Setting. Many modern video drivers do modesets in the kernel instead of in user space. Nouveau does a kernel modeset on boot, and then uses that mode to display a framebuffer console on your VT. The reason you can't unload nouveau is because it's now used to provide your text console. By disabling kernel modesetting, your text console will be displayed in VGA text mode, instead of a framebuffer console.

On Debian, edit your /boot/grub/menu.lst, and look for the section that starts with "### BEGIN AUTOMAGIC KERNELS LIST". Go down to the line that starts with "# defoptions=" and add the option "nouveau.modeset=0" to the end of that line. Then run update-grub and reboot.

You can also add the option at boot time by selecting your kernel in the bootloader and pressing 'e' to edit the boot options.

Quote:
For now, I will try /etc/modprobe.d/blacklist.conf file, I added to the bottom of the list with:
blacklist nouveau

I hope that's OK. I think I have to reboot for this to take an effect?
Yes, you can add that to blacklist.conf, and yes you'll have to reboot for that to take effect; however, if nouveau is in your initrd and you don't disable KMS, you'll still end up stuck with the same problem.
danix is offline   Reply With Quote