View Single Post
Old 06-04-10, 04:53 PM   #10
A GeForced Ant
ant's Avatar
Join Date: Sep 2002
Location: An Ant Farm
Posts: 348
Question Re: insmod: error inserting './usr/src/nv/nvidia.ko and can't find my NVIDIA card?

Originally Posted by danix View Post
You can't remove it because it's done the KMS. I'll explain below.

KMS is Kernel Mode Setting. Many modern video drivers do modesets in the kernel instead of in user space. Nouveau does a kernel modeset on boot, and then uses that mode to display a framebuffer console on your VT. The reason you can't unload nouveau is because it's now used to provide your text console. By disabling kernel modesetting, your text console will be displayed in VGA text mode, instead of a framebuffer console.

On Debian, edit your /boot/grub/menu.lst, and look for the section that starts with "### BEGIN AUTOMAGIC KERNELS LIST". Go down to the line that starts with "# defoptions=" and add the option "nouveau.modeset=0" to the end of that line. Then run update-grub and reboot.

You can also add the option at boot time by selecting your kernel in the bootloader and pressing 'e' to edit the boot options.

Yes, you can add that to blacklist.conf, and yes you'll have to reboot for that to take effect; however, if nouveau is in your initrd and you don't disable KMS, you'll still end up stuck with the same problem.
Thanks for the informative post. It makes sense. Now, I know why my text console is all tiny! I was trying to fix that but without luck, but it appears to be related to this Nouveau! I prefer that old fashion VGA (80x25!) since my eye sights are bad.

I don't have a /boot/grub/menu.lst, but didn't Grub2 change this? I don't use the original Grub anymore. I don't know where your suggestion goes.

As for blacklist.conf, I will undo the change since you say I will still have problems. I assume only Grub's boot with nouveau.modeset=0 would be enough to fix this problem? Or is there something more?
Ant @ The Ant Farm ( and Ant's Quality Foraged Links (
ant is offline   Reply With Quote