View Single Post
Old 06-14-10, 11:53 AM   #2
Registered User
deva1984's Avatar
Join Date: Jun 2010
Posts: 2
Default Re: cann't start x after kernel upgrade

drat. i've thought the problem was resolved.

since i updated xserver-xorg using "aptitude update/upgrade" this morning, i could start x server now.

root:/var/log# glxinfo | grep render
Error: glXCreateContext failed
root:/var/log# grep -n '^(EE)' Xorg.0.log
131: (EE) Jun 15 01:29:18 NVIDIA(0): Failed to initialize the GLX module; please check in your X
132: (EE) Jun 15 01:29:18 NVIDIA(0): log file that the GLX module has been loaded in your X
133: (EE) Jun 15 01:29:18 NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
134: (EE) Jun 15 01:29:18 NVIDIA(0): you continue to encounter problems, Please try
135: (EE) Jun 15 01:29:18 NVIDIA(0): reinstalling the NVIDIA driver.
i found xserver-xorg apparently replaced the file with his own's
root:/usr/lib/xorg/modules/extensions# ls -l
total 3492
-rw-r--r-- 1 root root 15168 Jun 3 18:14
-rw-r--r-- 1 root root 10008 Jun 3 18:14
-rw-r--r-- 1 root root 33944 Jun 3 18:14
-rw-r--r-- 1 root root 117296 Jun 3 18:14
-rw-r--r-- 1 root root 332256 Jun 3 18:14
-rwxr-xr-x 1 root root 3014344 Jun 15 01:09
-rw-r--r-- 1 root root 24588 Jun 3 18:14
"glx" lines in Xorg.0.log file
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.7.7, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
Then i updated nividia driver to version 195.36.31, and left nothing in xorg.conf file but
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"

Still meeting the same problem as yesterday, x server crashed.
I upload the both Xorg.0.log files
Attached Files
File Type: txt Xorg.0.log-nvidia.txt (14.9 KB, 97 views)
File Type: txt Xorg.0.log-xorg.txt (15.0 KB, 86 views)

Last edited by deva1984; 06-14-10 at 07:15 PM. Reason: update
deva1984 is offline   Reply With Quote