View Single Post
Old 06-22-10, 03:43 PM   #1
OggY68
Registered User
 
Join Date: Jun 2010
Posts: 7
Unhappy Jerky Video Playback with TV-OUT PAL 625

Hello, I'm trying for months to get smooth playback using nvidia's tv-out on a classic CRT TV 4:3 but to no avail. Everyting is ok but the video stutters every 3 to 5 seconds even when using 25fps video files. This the case when using mplayer and VLC for playback. Nvidia never accepts custom made modes and modelines even when forcing, see xorg log:

Xorg.1.log

Xorg.conf:

////////////// BEGIN //////////////////
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder75) Thu Apr 22 11:44:23 PDT 2010
Section "ServerFlags"
Option "DefaultServerLayout" "Layout0"
Option "Xinerama" "0"
EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "ServerLayout"
Identifier "Layout1"
Screen 0 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "be"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Medion"
ModelName "MED MD30422PV"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
HorizSync 13.0 - 16.0
VertRefresh 50.0 - 60.0
Modeline "720x576pali" 13.88 720 742 808 888 576 580 583 625 -hsync -vsync interlace
Modeline "704x576pali" 13.50 704 722 786 864 576 580 583 625 -hsync -vsync interlace
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
BusID "PCI:5:0:0"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9800 GT"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
BusID "PCI:5:0:0"
Option "NoLogo"
Option "RenderAccel" "1"
Option "TVOutFormat" "SVIDEO"
Option "TVStandard" "PAL-B"
Option "UseDisplayDevice" "TV"
Option "TVOverScan" "0.2"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
#Option "XAANoOffscreenPixmaps" "true"
#Option "AllowGLXWithComposite" "true"
Option "TwinView" "0"
Option "metamodes" "1680x1050_60 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "UseEDID" "FALSE"
Option "ModeValidation" "AllowInterlacedModes"
Option "ModeValidation" "NoPredefinedModes"
Option "ModeValidation" "NoXServerModes"
Option "ModeValidation" "NoEdidModes"
Option "ModeValidation" "NoVesaModes"
Option "ModeValidation" "AllowNon60HzDFPModes"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "720x576pali" "704x576pali"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "disable"
EndSection
//////////////////////END //////////////////////

Launch Script:

///////////////// BEGIN //////////////////
#!/bin/sh

#exec /usr/bin/xinit /usr/bin/xterm -ut -e \
# /usr/bin/mplayer -stop-xscreensaver -fs -vo sdl "$@" -- /usr/bin/X :1 -layout Layout1

/usr/bin/X :1 -layout Layout1 &
export DISPLAY=:1
xhost localhost
# or modify startx to create 2 magic cookies at startup:
# authdisplay=${display:-:0 :1} <--edit in the :1
# and prepend DISPLAY=:1 to all commands to be run on :1
nvidia-settings -a :1.0/SyncToVBlank=1 &
nvidia-settings -a :1.0/AllowFlipping=1 &
nvidia-settings -a :1.0/XVideoTextureSyncToVBlank=1 &
nvidia-settings -a :1.0/XVideoBlitterSyncToVBlank=1 &
nvidia-settings -a :1.0/XVideoSyncToDisplay=256 &
nvidia-settings -a :1.0/TVOverScan[TV-0]=10 &
#nvidia-settings -q all > ~/Temp/tvout.txt &
sleep 1 &
/usr/bin/mplayer -stop-xscreensaver -fs -vo vdpau -af volume=15:1 "$*"

pkill -f "layout Layout1"

///////////////////END////////////////////////////////

This issue is driving me crazy, any help would be very much appreciated
OggY68 is offline   Reply With Quote