View Single Post
Old 07-06-10, 01:22 PM   #66
Satarsa
Registered User
 
Join Date: Jul 2010
Posts: 3
Default Re: Linux backlight driver

Quote:
Originally Posted by damdim View Post
I changed a little the source so it can compile against a 2.6.34 kernel. The changes were copied from MacTel Team latest module (https://launchpad.net/~mactel-support/+archive/ppa). Change the .min and .max values to fit your hardware and add the pci id to "static DEFINE_PCI_DEVICE_TABLE(nvidia_bl_device_table)" section accordingly from http://us.download.nvidia.com/XFree8...ppendix-a.html if your card is not already there.
P.S. It will compile only against a 2.6.34 kernel. For a previous kernel use the original source from guillaumezin in the first post.
For me these code doesn't work. gcc says that FB_BACKLIGHT_LEVELS is not defined. How should it be done?
Satarsa is offline   Reply With Quote