View Single Post
Old 07-07-10, 07:54 AM   #5
Tommi A.
Registered User
 
Join Date: Jun 2010
Location: Helsinki, Finland
Posts: 4
Default Re: Dragging a window on Ubuntu Linux desktop results in screen tearing

Quote:
Originally Posted by hl_ View Post
If you disable DynamicTwinView (see the driver documentation), automatic refresh rate detection should work. VSync is still disabled by default, but I don't know why.
This sounds like something I could try!

But first: I noticed I wasn't using the latest stable version of the NVIDIA x64 display driver so I downloaded and installed version 256.35. It works well but the screen tearing is still present so I'm going to try out your suggestion.

According to the driver documentation Dynamic TwinView can be disabled by setting the "DynamicTwinView" X configuration option to FALSE.

I did this by editing xorg.conf and then restarting Ubuntu.
Code:
sudo gedit /etc/X11/xorg.conf
Here is my xorg.conf file:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 256.35  (buildmeister@builder97.nvidia.com)  Wed Jun 16 19:15:05 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "DynamicTwinView" "False"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Afterwards I also went to System-->Adminisration-->NVIDIA X Server Settings and enabled Sync to VBlank (in XServer XVideo Settings) and Sync to VBlank and Allow Flipping (in OpenGL Settings).

Unfortunately this didn't help and the same screen tearing still takes place.
Tommi A. is offline   Reply With Quote